B-1002

Description

Two different circles can have at most four common tangents.

The picture below is an illustration of two circles with four common tangents.

Now given the center and radius of two circles, your job is to find how many common tangents between them.

Input

The first line contains an integer T, meaning the number of the cases (1 <= T <= 50.).

For each test case, there is one line contains six integers x1 (−100 ≤ x1 ≤ 100), y1 (−100 ≤ y1 ≤ 100), r1 (0 < r1 ≤ 200), x2 (−100 ≤ x2 ≤ 100), y2 (−100 ≤ y2 ≤ 100), r2 (0 < r2 ≤ 200). Here (x1, y1) and (x2, y2) are the coordinates of the center of the first circle and second circle respectively, r1 is the radius of the first circle and r2 is the radius of the second circle.

Output

For each test case, output the corresponding answer in one line.

If there is infinite number of tangents between the two circles then output -1.

Sample Input

310 10 5 20 20 510 10 10 20 20 1010 10 5 20 10 5

Sample Output

423

题意:

有两个圆,分别输入它们的圆心以及半径,然后要求输出它们的公切线!

思路:

此问题总共有五种可能,即圆的五种位置关系!(1)两圆相同,此时有无数条公切线,输出-1.(2)相离,有2条公切线(3)外切,有3条公切线(4)相交,有2条公切线(4)内含,没有公切线,即为0!使用ifelse 语句即可!

细节:

注意,外切时是3条切线,不是两条!

代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
using namespace std;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int x1, y1, r1, x2, y2, r2;
        cin>>x1>>y1>>r1>>x2>>y2>>r2;
        double d;
        d = sqrt( 1.0*((x1-x2)*(x1-x2) + (y2-y1)*(y2-y1)) );
        int a;
        if(d==0.0 && r1==r2)
        a = -1;
        else  if(d > 1.0*(r1+r2))
        a = 4;
        else  if(d==1.0*(r1+r2))
        a = 3;
        else  if(d>1.0*(fabs(r1-r2)) && d < 1.0*(r1+r2))
         a = 2;
        else  if(d==1.0*(fabs(r1-r2)))
         a = 1;
        else  if(d < 1.0*(fabs(r1-r2)))
        a = 0;
        cout<<a<<endl;
    }
    return 0;
}

心得:

学好数学至关重要啊!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值