G - 07

Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000


题意:

就是有一根细棒,加热之后就会膨胀,但它的高度不会超过原长的一半,让你求他的变化高度h!

思路:

数学问题和二分查找!经过计算可以求出,R=(L0^2+4*h^2)/(8*h);L1=2*R*arcsin(L0/(2*R))

可以用二分枚举h的值,计算出R和L1,与题目中的L1进行比较!!!!!

代码:

#include <stdio.h>
#include <iostream>
#include <iomanip>>
#include <math.h>
using namespace std;
int main()
{
    double L0,L1,N,C;
    double high,low,h,r,L2,esp=1E-6;
    while (cin>>L0>>N>>C)
    {
    	if(L0<0&&N<0&&C<0)
    	break;
        L1=(1+N*C)*L0;
        high=0.5*L0;
        low=0.0;
        while (high-low>esp)
        {
            h=(high+low)/2;
            r=(L0*L0+4*h*h)/(8*h);
            L2=2*r*asin(L0/(2*r));
            if (L1<L2) high=h;
            else low=h;
        }
        h=(high+low)/2;
        cout<<fixed<<setprecision(3)<<h<<endl;
    }
    return 0;
}
心得:

貌似是第一次接触含有数学的问题!感觉困难!!!!此题是看了题解,自己始终卡在求值上,即数学问题不会分析!!以后要加强训练!!!!


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值