Number Sequence

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 
Output
For each test case, print the value of f(n) on a single line.
 
Sample Input
1 1 3
1 2 10
0 0 0
 
Sample Output
2
5
 
Author
CHEN, Shunbao
 
Source
ZJCPC2004
 
Recommend
JGShining
 


关键在于循环节的寻找,

代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
int g,n,a,b,i,j,f[1000],ii,jj;
while(cin>>a>>b>>n,a||b||n){
g=f[1]=f[2]=1;
for(i=3;i<=n&&i<1000;i++)f[i]=0;
for(i=3;i<=n&&g;i++)
{
f[i]=(a*f[i-1]+b*f[i-2])%7;//寻找循环节
for(j=1;j<i-1;j++)
if(f[j]==f[i-1]&&f[j+1]==f[i])
{
g=0;
ii=i;    //终点
jj=j;//起点break;
}
}
if(g)
cout<<f[n]<<endl; //没有循环时直接输出
else
{
n=(n-jj+1)%(ii-1-jj);   //据循环来求n
if(n==0)
n=n+ii-1-jj;
cout<<f[jj+n-1]<<endl;
}
}
return 0;
}

思路:

寻找循环节,是解题的一个好办法!!!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值