Just a Hook(线段树 )

Just a Hook

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 36   Accepted Submission(s) : 14
Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.
 

Source
2008 “Sunline Cup” National Invitational Contest
 

线段树功能:update:成段替换 (由于只query一次总区间,所以可以直接输出1结点的信息)

代码:

#include <iostream>
#include <stdio.h>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm> 
using namespace std;
const int maxn=100000+10;
int n,sum;
struct node{     //
	int l,r;
	int n;
}a[maxn<<2];
void build(int l,int r,int i)  //建树
{
	a[i].l=l;
	a[i].r=r;
	a[i].n=1;
	if(l!=r)
	{
		int mid=(l+r)>>1;
		build(l,mid,2*i);
		build(mid+1,r,2*i+1);
	}
}
void update(int i,int x,int y,int m)  //更新区间值
{
	if(a[i].n==m)return;   //相同就不用修改
	if(a[i].l==x&&a[i].r==y) //找到了区间,直接进行更新
	{
		a[i].n=m;
		return;
	}
	if(a[i].n!=-1) //该区间只有一个值的情况
	{
		a[2*i].n=a[2*i+1].n=a[i].n;//由于后面必定对子树操作,所以更新子树的值等于父亲的值
		a[i].n=-1;//由于该区域颜色与修改不同,而且不是给定区域,所以该区域必定为杂色  
	}
       //父区间为杂色时对所有子节点进行操作  
	int mid=(a[i].l+a[i].r)>>1;
	if(x>mid)
	update(2*i+1,x,y,m);
	else if(y<=mid)
	update(2*i,x,y,m);
	else
	{
		update(2*i,x,mid,m);
		update(2*i+1,mid+1,y,m);
	}
} 
int query(int i)  //查询某一结点所包含的结果的值的和
{
	if(a[i].n!=-1)
	return (a[i].r-a[i].l+1)*a[i].n;
	else
	return query(2*i)+query(2*i+1); 
}
int main()
{
	ios::sync_with_stdio(false); //不加这句话会超时
	int t,i,k,x,y,m;
	int cas=1;
	cin>>t;
	while(t--)
	{
		cin>>n>>k;
		build(1,n,1);
		while(k--)
		{
			cin>>x>>y>>m;
			update(1,x,y,m);
			
		}
		 printf("Case %d: The total value of the hook is %d.\n",cas++,query(1)); 
	}

}



#include <cstdio>  
#include <algorithm>  
using namespace std;  
   
#define lson l , m , rt << 1  
#define rson m + 1 , r , rt << 1 | 1  
const int maxn = 111111;  
int h , w , n;  
int col[maxn<<2];  
int sum[maxn<<2];  
void PushUp(int rt) {  
    sum[rt] = sum[rt<<1] + sum[rt<<1|1];  
}  
void PushDown(int rt,int m) {  
    if (col[rt]) {  
        col[rt<<1] = col[rt<<1|1] = col[rt];  
        sum[rt<<1] = (m - (m >> 1)) * col[rt];  
        sum[rt<<1|1] = (m >> 1) * col[rt];  
        col[rt] = 0;  
    }  
}  
void build(int l,int r,int rt) {  
    col[rt] = 0;  
    sum[rt] = 1;  
    if (l == r) return ;  
    int m = (l + r) >> 1;  
    build(lson);  
    build(rson);  
    PushUp(rt);  
}  
void update(int L,int R,int c,int l,int r,int rt) {  
    if (L <= l && r <= R) {  
        col[rt] = c;  
        sum[rt] = c * (r - l + 1);  
        return ;  
    }  
    PushDown(rt , r - l + 1);  //当前节点信息传递子节点
    int m = (l + r) >> 1;  
    if (L <= m) update(L , R , c , lson);  
    if (R > m) update(L , R , c , rson);  
    PushUp(rt);  
}  
int main() {  
    int T , n , m;  
    scanf("%d",&T);  
    for (int cas = 1 ; cas <= T ; cas ++) {  
        scanf("%d%d",&n,&m);  
        build(1 , n , 1);  
        while (m --) {  
            int a , b , c;  
            scanf("%d%d%d",&a,&b,&c);  
            update(a , b , c , 1 , n , 1);  
        }  
        printf("Case %d: The total value of the hook is %d.\n",cas , sum[1]);  
    }  
    return 0;  
}  


  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值