F - TELE (数学dp+01背包)

A TV-network plans to broadcast an important football match. Their network of transmitters and users can be represented as a tree. The root of the tree is a transmitter that emits the football match, the leaves of the tree are the potential users and other vertices in the tree are relays (transmitters). 
The price of transmission of a signal from one transmitter to another or to the user is given. A price of the entire broadcast is the sum of prices of all individual signal transmissions. 
Every user is ready to pay a certain amount of money to watch the match and the TV-network then decides whether or not to provide the user with the signal. 
Write a program that will find the maximal number of users able to watch the match so that the TV-network's doesn't lose money from broadcasting the match.
Input
The first line of the input file contains two integers N and M, 2 <= N <= 3000, 1 <= M <= N-1, the number of vertices in the tree and the number of potential users. 
The root of the tree is marked with the number 1, while other transmitters are numbered 2 to N-M and potential users are numbered N-M+1 to N. 
The following N-M lines contain data about the transmitters in the following form: 
K A1 C1 A2 C2 ... AK CK 
Means that a transmitter transmits the signal to K transmitters or users, every one of them described by the pair of numbers A and C, the transmitter or user's number and the cost of transmitting the signal to them. 
The last line contains the data about users, containing M integers representing respectively the price every one of them is willing to pay to watch the match.
Output
The first and the only line of the output file should contain the maximal number of users described in the above text.
Sample Input
9 6
3 2 2 3 2 9 3
2 4 2 5 2
3 6 2 7 2 8 2
4 3 3 3 1 1
Sample Output
5


题目意思:一个电视台的信号发射塔和用户以及传输线路之间构成了一个树状结构,根节点代表发射塔,叶子节点代表用户,树的每一条边都有权值代表传输的代价,问从发射塔发射信号,如何在电视台没有损失的情况下使得最多的用户看到电视节目;

思路:

树形dp,dp[i][j]表示i为根的子树,j个观众的利润。注意dp[i][0]全部初始化为0,其余全部初始化为-inf。还有就是关于叶子结点的判断。具体见代码

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
using namespace std;
const int maxn=3010;
struct Edge{
int to;
int len;
int next;
}edge[maxn*3];  //建立结构体

int N, M;
int head[maxn];//前驱节点
int dp[maxn][maxn];//i为根j个人时的利润
int num[maxn];//以i为根的结点,有多少个观众
int vis[maxn];//访问没访问过
int cost[maxn];//消费
int tot;
void add(int u,int v,int len){  //建树
    edge[++tot].next=head[u];
    edge[tot].to=v;
    edge[tot].len=len;
    head[u]=tot;
}

void dfs(int now)
{
    vis[now]=1;
    if(now>=N-M+1){  //叶子结点
        dp[now][1]=cost[now];
        num[now]=1;
        return;
    }
	for (int i = head[now]; i!=0; i=edge[i].next){  //i为边号
	    int next=edge[i].to; //下个点
        if(vis[next])continue;
        dfs(next);
		for (int j=M;j>=0;--j) //背包
			for (int k=num[next];k>=0;--k)
            if(j>=k){
                dp[now][j]=max(dp[now][j],dp[now][j-k]+dp[next][k]-edge[i].len);

            }
            num[now]+=num[next];
	}
	return;
}

int main()
{
    ios::sync_with_stdio(0);
    int i,k,v,len;
	while (cin>>N>>M)
	{
	    tot=0;
	    memset(dp,-0x3f,sizeof(dp));
	    memset(vis,0,sizeof(vis));
	    memset(num,0,sizeof(num));
	    memset(edge,0,sizeof(edge));
	    memset(head,0,sizeof(head));

		for (i =1; i<=N-M; i++)dp[i][0]=0;

		for (i=1;i<=N-M;i++)
		{
			cin >>k;
			for(int j=1;j<=k;j++){
                cin>>v>>len;
                add(i,v,len);
                add(v,i,len);
			}
		}
		for(i=N-M+1;i<=N;i++){
            cin>>cost[i];
		}
		dfs(1);
		int index;
		for(i=1;i<=M;i++){
		    if(dp[1][i]>=0){  //只要是正的即可
                index=i;
		    }
		}
		cout<<index<<endl;
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值