ZOJ3469:Food Delivery(区间DP)

When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person's coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one's Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people's Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

Input

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231 - 1.

Please process to the end-of-file.

Output

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

Sample Input

5 1 0
1 1
2 2
3 3
4 4
5 5

Sample Output

55


题意思路:

有一家快餐店送外卖,现在同时有n个家庭打进电话订购,送货员得以1/V的速度一家一家的运送,但是每一个家庭都有一个不开心的值,每分钟都会增加一倍,值达到一定程度,该家庭将不会再订购外卖了,现在为了以后有更多的家庭订购,要将外卖送到的情况下使得所有用户的不开心值总和达到最小

    很明显,每多走一分钟,没送到的家庭的不开心值都会加倍,

    假设是这样的顺序123X456,从X出发先往左右中间靠近的送,再往两边送省时间

       dp[i][j][0]表示从i到j用户送到最小不开心值,此时送货员停留在左边即i位置

       dp[i][j][1]表示从i到j用户送到最小不开心值,此时送货员停留在右边即j位置

    状态有四种,

    dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(a[i+1].x-a[i].x)*(delay+a[i].v));

    dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(a[j].x-a[i].x)*(delay+a[i].v));

    dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][0]+(a[j].x-a[i].x)*(delay+a[j].v));

    dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][1]+(a[j].x-a[j-1].x)*(delay+a[j].v));

代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 1005
#define INF 0x7ffffff
int dp[N][N][2];
int n,V,X;
int sum[N];

struct node
{
    int x;//位置 
    int v; //增长的值 
} a[N]; 
int cmp(node b,node c)
{
    return b.x<c.x;
}

int Delay(int l,int r)
{
    if(l>r)
        return 0;
    return sum[r]-sum[l-1];//延期增加的值 
}

void DP()
{
    int res;
    for(int i=1; i<=n; i++)
    {
        for(int j=1; j<=n; j++)
            dp[i][j][0]=dp[i][j][1]=INF;
    }
    for(int i=1; i<=n; i++)
    {
        if(a[i].x==X)  //送货员的位置 
        {
            res=i;
            break;
        }
    }
    dp[res][res][0]=dp[res][res][1]=0;
    
    for(int i=res; i>=1; i--) //i循环restaurant左边的
    {
        for(int j=res; j<=n; j++) //j循环restaurant右边的
        {
            int delay=Delay(1,i-1)+Delay(j+1,n);  //加的是i-j以外取完的时间所耽误的 
            if(i==j)
                continue;
       dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(a[i+1].x-a[i].x)*(delay+a[i].v));
       dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(a[j].x-a[i].x)*(delay+a[i].v));
       dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][0]+(a[j].x-a[i].x)*(delay+a[j].v));
            dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][1]+(a[j].x-a[j-1].x)*(delay+a[j].v));
        }
    }
}
int main()
{
    while(scanf("%d%d%d",&n,&V,&X)!=EOF)
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&a[i].x,&a[i].v);
        }
        a[n+1].x=X;
        a[n+1].v=0;
        n++;
        sort(a+1,a+n+1,cmp);
        memset(sum,0,sizeof(sum));
        for(int i=1; i<=n; i++)
            sum[i]=sum[i-1]+a[i].v;
        DP();
        printf("%d\n",min(dp[1][n][0],dp[1][n][1])*V);
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值