Proving Equivalences (有向图强连通+等价性证明)

Consider the following exercise, found in a generic linear algebra textbook. 

Let A be an n × n matrix. Prove that the following statements are equivalent: 

1. A is invertible. 
2. Ax = b has exactly one solution for every n × 1 matrix b. 
3. Ax = b is consistent for every n × 1 matrix b. 
4. Ax = 0 has only the trivial solution x = 0. 

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent. 

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications! 

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
InputOn the first line one positive number: the number of testcases, at most 100. After that per testcase: 

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved. 
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.OutputPer testcase: 

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.Sample Input
2
4 0
3 2
1 2
1 3
Sample Output
4
2

题意:

在数学中,我们常常需要完成若干个等价性证明。比如,有四个命题:  a,b,c,d.我们证明a<->b,冉恒b<->c,最后c<->d。注意每次证明都是双向的,因此一共完成了6次推导,另一种方法是证明a<->b,然后b<->c,接着 c<->d最后是d->a,只需4次。现在你的任务是证明n个命题全部等价,且你的朋友已经帮你做出来m次推导(已知每次推导的内容),你至少还需要做几次推导才能完成你的证名

思路:

如果把命题作为结点,推到看作有向边,则本题就是给出n个结点m条边的有向图,要求添加尽量少的边,使得新图强连通,算法如下,首先要找出强连通分量(find_scc函数),然后把每个强连通分量缩成一个点,得到一个DAG,接下来,设有a个结点(别忘了,这里的每一个节点对应原图的一个强连通分量)的入度为0,b个节点的出度为0,则max{a,b}就是答案,注意特殊情况,就是当原图已经强连通的时候,答案是0而不是1.

代码:

#include <iostream>
#include <cstdio>
#include <algorithm> 
#include <cstring>
#include <vector>
#include <cmath>
#include <queue>
#include <stack> 
#define ll long long
#define maxn 20000+10
using namespace std;
vector<int>G[maxn];
int pre[maxn],low[maxn],sccno[maxn],dfs_clocks,scc_cnt;
stack<int>s;
int in0[maxn],out0[maxn];
int n,m; 

void dfs(int u){
	pre[u]=low[u]=++dfs_clocks;
	s.push(u);
	for(int i=0;i<G[u].size();i++){
		int v=G[u][i];
		if(!pre[v]){
			dfs(v);
			low[u]=min(low[u],low[v]);
		} else if(! sccno[v]){
			low[u]=min(low[u],pre[v]);
		}
		
	}
	if(low[u]==pre[u]){
		scc_cnt++;
		while(true){
			int x=s.top();
			s.pop();
			sccno[x]=scc_cnt;
			if(x==u) break;
		}
	}
	
}

void find_scc(int n){
	dfs_clocks=0;
	scc_cnt=0;
	memset(sccno,0,sizeof(sccno));
	memset(pre,0,sizeof(pre));
	for(int i=0;i<n;i++){
		if(!pre[i])
		 dfs(i);
	}
}

int main()
{
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d%d",&n,&m);
		for(int i=0;i<n;i++) G[i].clear();
		for(int i=0;i<m;i++) {
			int u,v;
			scanf("%d%d",&u,&v);
			u--;
			v--;
			G[u].push_back(v);
		}
		find_scc(n);
		for(int i=1;i<=scc_cnt;i++) in0[i]=out0[i]=1;
		for(int u=0;u<n;u++){
			for(int i=0;i<G[u].size();i++){
				int v=G[u][i];
				if(sccno[u]!=sccno[v]) in0[sccno[v]]=out0[sccno[u]]=0;
			}
		}
		int a=0,b=0;
		for(int i=1;i<=scc_cnt;i++){
			if(in0[i]) a++;
			if(out0[i]) b++;
		}
		int ans=max(a,b);
		if(scc_cnt==1) printf("0\n") ;
		else printf("%d\n",ans);
	}

    return 0;
}




 
地址: 点击打开链接

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值