正方形(Java)acm.sdut

Problem Description
给出四个点,判断这四个点能否构成一个正方形。
Input
 输入的第一行包含一个整数T(T≤30)表示数据组数,每组数据只有一行,包括8个整数x1, y1, x2, y2,x3,y3,x4,y4(数据均在-1000,1000 之间)以逆时针顺序给出四个点的坐标。

Output
 每组数据输出一行,如果是正方形,则输出: YES, 否则,输出:NO。
Example Input
2
0 0 1 0 1 1 0 1
-1 0 0 -2 1 0 2 0
Example Output
YES
NO

有个地方需要注意:在求边边相等还有判断是不是直角三角形时,不需要在类中开根号,直接返回平方的值,简便计算。

否则到最后还要再改;


import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int t = sc.nextInt();
		for (int i = 0; i < t; i++) {
			int x1 = sc.nextInt();
			int y1 = sc.nextInt();
			int x2 = sc.nextInt();
			int y2 = sc.nextInt();
			int x3 = sc.nextInt();
			int y3 = sc.nextInt();
			int x4 = sc.nextInt();
			int y4 = sc.nextInt();

			Rect l1 = new Rect(x1, y1);
			Rect l2 = new Rect(x2, y2);
			Rect l3 = new Rect(x3, y3);
			Rect l4 = new Rect(x4, y4);

			int length1 = l1.length(l2);
			int length2 = l2.length(l3);
			int length3 = l3.length(l4);
			int length4 = l4.length(l1);
			int ml = l1.length(l3);
			if (length1 == length2 && length2 == length3 && length3 == length4
					&& length4 == length1) {
				if (length1 + length2 == ml) {
					System.out.println("YES");
				} else {

					System.out.println("NO");
				}

			} else {
				System.out.println("NO");
			}
		}

		sc.close();
	}
}

class Rect {
	int x, y;

	public Rect(int x, int y) {
		this.x = x;
		this.y = y;
	}

	public int length(Rect rect) {
		return (x - rect.x) * (x - rect.x) + (y - rect.y) * (y - rect.y);
	}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值