HDU——1325 Is It a Tree?(并查集 / 技巧解题)

Problem Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
这里写图片描述 这里写图片描述 这里写图片描述

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line Case k is a tree." or the lineCase k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

解题思路:

1.典型的并查集问题
2.简单算法:
题目要求的树满足三个条件:
1. 只有一个根节点
2. 除了根节点之外每个点的入度为 1
3. 无环    注:保证除了根节点之外的每个根节点的入度为1 ,便可以保证无环

注:在满足2的条件下 , 如果可以保证树的节点的个数 = 数的边的个数 + 1 , 那么此时必定可以满足上述三个条件。

代码:

#include<cstdio>
#include<cstring>
using namespace std;

int f[1000];

int main(){
   // freopen("D://testData//1325.txt" , "r" ,stdin);
    int a , b , k = 1;
    int node = 0;
    int arc = 0;
    int flag = 0;
    while(1){
        node = 0;
        arc = 0;
        flag = 0;
        memset(f , 0 ,sizeof(f));
        while(scanf("%d %d",&a , &b) && a && b){
            if(a < 0 && b < 0)
                return 0;
            if(f[b] == 2)  //说明这个点的入度 > 1;
                flag = 1;
            if(f[a] == 0)
                node ++ ;   //新增一个点
            if(f[b] == 0)
                node ++ ;   //新增一个点
            f[a] = 1;
            f[b] = 2;
            arc ++;    //每次都新增一条边
        }
        if(flag == 0 && node == arc + 1){  //如果是一棵树 , 则边的数量一点比点的数量少1
            printf("Case %d is a tree.\n" , k++);
        }else{
            printf("Case %d is not a tree.\n" , k++);
        }
    }
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值