杭电ACM_step1.2.1

先上原题:
Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output
Print the total time on a single line for each test case.

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41
还是感觉有点不习惯这种OJ平台太严谨的东西,下面是我的代码,虽然在Visual studio上可以运行,可是到了,OJ平台上却不行,不知道哪里出了问题,主要是练习嘛,我也 找不出错误在哪里,先就这样吧。嗯,上代码:


#include<stdio.h>

int main()
{
    int N, i, a[1000];                         /*先定义一个数组,用来处理输入的N个数据*/
    int sum = 0;                               /*起始时先将sum置0*/
    int arr_sum[1000];
    int count = 0;

    while (1)
    {
        scanf("%d", &N);
        if (N == 0)break;
            for (i = 0; i < N; i++)
            {
                scanf("%d", &a[i]);          /*输入这N个数,并且存储到数组中*/
            }
            sum = a[0] * 6 + 5;   /*为sum赋初值*/
            for (i = 1; i < N; i++)          /*因为初值设置为a[0],所以数组从1开始*/
            {
                if (a[i]>a[i - 1])
                    sum = sum + (a[i] - a[i - 1]) * 6 + 5;  /*则需要6秒*/
                else if (a[i] < a[i - 1])
                    sum = sum + (a[i - 1] - a[i]) * 4 + 5;  /*向下需要4秒*/
            }
            arr_sum[count++] = sum;
            sum = 0;                                       /*每次循环后将sum置为0.*/
        }
        if(count!=0)
    for (i = 0; i < count; i++)
    {
        printf("%d\n", arr_sum[i]);
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值