hdu1164 Eddy's research I

Problem Description
Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

 

Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
 

Output
You have to print a line in the output for each entry with the answer to the previous question.
 

Sample Input
  
  
11 9412
 

Sample Output
  
  
11 2*2*13*181
 

Author
eddy


C语言AC代码
#include<stdio.h>
#include<string.h>
int num[70000],prime[50000];
#define N 70000
void primes()
{
    int i,j,k;
    k=0;
    memset(num,0,sizeof(num));
    for(i=2; i<N; i++)
    {
        if(num[i]==0)
            prime[k++]=i;
        for(j=0; (j<k)&&(i*prime[j])<N; j++)
        {
            num[i*prime[j]]=1;
            if(i%prime[j]==0)
                break;
        }
    }
}
int main()
{
    int x;
    int ans[100];
    primes();
    while(scanf("%d",&x)!=EOF)
    {
        int i,j=0;
        for(i=0; prime[i]<=x; i++)
        {
            if(x==0||x==1)
                break;
            if(x%prime[i]==0)
            {
                ans[j++]=prime[i];
                x=x/prime[i];
                i=-1;
            }
        }
        for(i=0; i<j; i++)
        {
            if(i<j-1)
                printf("%d*",ans[i]);
            else
                printf("%d\n",ans[i]);
        }
    }
    return 0;
}

思路:输入x后,每次要记得从第一个素数开始,找到x可以除尽的素数记录下来。

筛素数法:1一个素数的倍数不是素数;2一个数与素数的乘积必然不是素数;3一个数是素数的倍数,它就不用与之后的素数相乘

可以参见我以前写的一道题目:http://blog.csdn.net/sinat_39591298/article/details/76695928

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值