sincerit-杭电oj 1212 Big Number

杭电oj 1212 Big Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9940 Accepted Submission(s): 6677

Problem Description
As we know, Big Number is always troublesome. But it’s really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.

Output
For each test case, you have to ouput the result of A mod B.

Sample Input
2 3
12 7
152455856554521 3250

Sample Output
2
5
1521

解法就是下面的代码
那为什么这样算就能得到答案呢?
举个例子 设大数为 1234, mod = 5;
1234 = 1 * 1000 + 2 * 100 + 3 * 10 + 4
= ((((1 * 10) + 2) * 10 + 3) * 10) + 4
假设 x = (((1 * 10) + 2) * 10 + 3), 最后一位数为m
所有的大数都可以表示成 x * 10 + m;
要求出 x * 10 + m的余数
由 (A + B) % C = (a%C + B%C) % C 可知
ans = (x * 10) % C + m % C
而m % C是很容易求的,那就是要求出x的余数才能得到答案
而x的余数也是像上面一样的求法,
具体点求余数就是求出 (1 * 10) + 2) * 10 % C + 3 % C
求(1 * 10) + 2)的余数 就是求 (1 * 10)% C + 2 % C
如下代码

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
using namespace std;
int main() {
  char num[1005];
  int m;
  while (~scanf("%s%d", num, &m)) {
    int sum = 0;
    for (int i = 0; i < strlen(num); i++) {
      sum = (sum * 10 % m + (num[i] - '0') % m) % m;
    }
    printf("%d\n", sum);
  } 
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值