Mayor’s posters
The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.
They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters’ size, their place and order of placement on the electoral wall.
Input
The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,… , ri.
Output
For each input data set print the number of visible posters after all the posters are placed.
The picture below illustrates the case of the sample input.
Sample Input
1
5
1 4
2 6
8 10
3 4
7 10
Sample Output
4
题意:有一面用来贴海报的墙,海报的高度和墙的高度相同,现按照顺序给出每n张海报在墙上的,位置(即宽度的起始),问最后能看到几张海报
思路:由于海报宽度很大不能直接使用树状数组,所以使用离散化处理(利用从小到大排序后的下标缩短海报宽度),然后利用i表示每一种海报并区间更新树,最后query整个区间统计未被标记的海报即为答案
#include <iostream>
#include <fstream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#include <cmath>
#include <algorithm>
#include <functional>
#define inf 0X3f3f3f3f
using namespace std;
typedef long long ll;
const int MAXN=1e9+10;
const int MAX=1e5+10;
int n,m;
pair<int,int>s[MAX];
int num[MAX],tree[MAX*4];
bool vis[MAX];
int ans;
void push_down(int node){
if(tree[node]!=-1){
tree[node<<1]=tree[node<<1|1]=tree[node];
tree[node]=-1;
}
}
void updata_tree(int node,int l,int r,int x,int y,int flag){
if(x<=l&&r<=y){
tree[node]=flag;
return ;
}
push_down(node);
int mid=(l+r)>>1;
if(x<=mid)
updata_tree(node<<1,l,mid,x,y,flag);
if(y>mid)
updata_tree(node<<1|1,mid+1,r,x,y,flag);
}
void query(int node,int l,int r){
if(tree[node]!=-1){
if(!vis[tree[node]])//标记
ans++;
vis[tree[node]]=1;
return ;
}
if(l==r) return;
int mid=(l+r)>>1;
query(node<<1,l,mid);
query(node<<1|1,mid+1,r);
}
int main(){
#ifdef SIYU
freopen("in.txt","r",stdin);
#endif // SIYU
int T;
cin>>T;
while(T--){
ans=0;
memset(vis,0,sizeof(vis));
cin>>n;
int cnt=1;
for(int i=0;i<n;i++){
scanf("%d%d",&s[i].first,&s[i].second);
num[cnt++]=s[i].first;
num[cnt++]=s[i].second;
}
sort(num+1,num+cnt+1);
cnt=unique(num+1,num+cnt+1)-(num+1);//去重
for(int i=cnt-1;i>=1;i--){
if(num[i]!=num[i-1]+1) //防止过度,盖住不应该盖住海报
num[cnt++]=num[i-1]+1;
}
sort(num,num+cnt);
memset(tree,-1,sizeof(tree)); //初始化,-1没有海报
for(int i=0;i<n;i++){ // 离散化,再更新树
int x=lower_bound(num,num+cnt,s[i].first)-num;
int y=lower_bound(num,num+cnt,s[i].second)-num;
updata_tree(1,0,cnt,x,y,i);//利用i来表示每一个海报
}
query(1,0,cnt);
cout<<ans<<endl;
}
return 0;
}