poj 2528 线段树的离散化

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters’ size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,… , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.
在这里插入图片描述
Sample Input

1
5
1 4
2 6
8 10
3 4
7 10
Sample Output

4

题目给你n张海报,海报的贴的范围是li~ri,每次贴的海报都不一样,后面贴的海报能覆盖前面的海报,问你最终能看到几种海报。
由于题目给的海报范围是1e7,直接用这个数据建线段树是做不到的。做的时候直接用珂朵莉树过了,现在补一下离散化。

虽然li和ri的范围到了1e7,但是最多只有1e4张海报,所以我们重新给出现的点编号。例如题目中只出现了1 3 7 9四个点,那么对应下标则是1 2 3 4,然后以此来建树。这里要注意一点,要在重新编辑后的差值大于1的两点中间再插入一个点。因为如果题目给你的是{3, 5} , {1, 3}, {5, 6}这样的组合,直接写的话最终{1, 3, 5, 6}的颜色对应为{2, 2, 3, 3},就只有两种颜色了,但其实3和5中间的4还是颜色1,会造成误差。

#include<iostream>
#include<cstdio>
#include<vector>
#include<set>
#include<algorithm>
#define outtime() cerr<<"User Time = "<<(double)clock()/CLOCKS_PER_SEC<<endl
#define S_IT set<Node>::iterator
using namespace std;
#define lowbit(x) x&-x
const int N = 1e5 + 10;
typedef long long ll;
int n, m;
int a[N], b[N], c[N];
struct SEG{
	int t[N << 2];
	void build(int id, int l, int r){
		t[id] = 0;
		if(l == r) return;
		int mid = (l + r) >> 1;
		build(id << 1 , l, mid);
		build(id << 1 | 1, mid + 1, r);
	}
	void down(int id){
		if(t[id] == 0) return;
		t[id << 1] = t[id];
		t[id << 1 | 1] = t[id];
		t[id] = 0;
	}
	void modify(int id, int l, int r, int ql, int qr , int v){
		if(l >= ql && r <= qr){
			t[id] = v;
			return;
		}
		down(id);
		int mid = (r + l) >> 1;
		if(ql <= mid) modify(id << 1, l, mid, ql, qr, v);
		if(qr > mid) modify(id << 1 | 1, mid + 1, r, ql, qr, v);
	}
	int query(int id, int l, int r, int p){
		if(l == r) return t[id];
		int mid = (l + r) >> 1;
		down(id);
		if(p <= mid) return query(id << 1, l, mid, p);
		else return query(id << 1 | 1, mid + 1, r, p);
	}
}seg;

int q;
int cnt;
set<int>st;
void solve(){
	scanf("%d", &n);
	cnt = 0;
	st.clear();
	for(int i = 1; i <= n; ++i){
		scanf("%d %d", &a[i], &b[i]);
		c[++cnt] = a[i];
		c[++cnt] = b[i];
	}
	sort(c + 1, c + 1 + cnt);
	q = unique(c + 1, c + 1 + cnt) - c - 1;
	int tmp = q;
	for(int i = 2; i <= tmp; ++i){
		if(c[i] - c[i - 1] > 1) c[++q] = c[i] - 1; //插入中间点
	}
	sort(c + 1, c + 1 + q);
	seg.build(1, 1, q);
	for(int i = 1; i <= n; ++i){
		int l = lower_bound(c + 1, c + 1 + q, a[i]) - c;
		int r = lower_bound(c + 1, c + 1 + q, b[i]) - c;
		seg.modify(1, 1, q, l, r, i);
	}
	
	for(int i = 1; i <= q; ++i){
		int cor = seg.query(1, 1, q, i);
		if(cor) st.insert(cor);
	}
	printf("%d\n", st.size());
}
int T;
int main(){
	scanf("%d", &T);
	while(T--)
		solve();
	return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值