@2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大) @HDU5534 (Dp,完全背包)

题目描述

In mathematics, and more specifically in graph theory, a tree is an undirected graph in which any two nodes are connected by exactly one path. In other words, any connected graph without simple cycles is a tree.
You find a partial tree on the way home. This tree has n nodes but lacks of n   1 edges. You want to complete this tree by adding n - 1 edges. There must be exactly one path between any two nodes after adding. As you know, there are nn−2 ways to complete this tree, and you want to make the completed tree as cool as possible.
The coolness of a tree is the sum of coolness of its nodes. The coolness of a node is f(d), where f is a predefined function and d is the degree of this node. What’s the maximum coolness of the completed tree?

 

输入

The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer
n in one line, then one line with n-1 integers f(1), f(2), . . . , f(n-1).
1≤T≤2015
2≤n≤2015
0≤f(i)≤10000
There are at most 10 test cases with n > 100.

 

输出

For each test case, please output the maximum coolness of the completed tree in one line.

 

样例输入

2
3
2 1
4
5 1 4

 

样例输出

5
19

 

图, 每个度 都有一个权值,

n-1条边 去构造图,   尽量满足可以形成图的情况下, 度数权值最大.求最大值.

 

题解:

很容易想到 背包,   ,而且是不限量的背包,  即完全背包.  

一个图的度数 是固定的 即 2*n-2;  又要保证图存在, 那么每个点至少度为1.  则   容量为 n-2

即 n个点分配n-2的度.

那么完全背包 可解:

初始值为 n*f[1]    背包的时候  权值为 f[i+1] -f[1]  就可以/

[代码]


#include <bits/stdc++.h>
#include <stdio.h>
#define rep(i,a,n) for(int i=a;i<=n;i++)
#define per(i,a,n) for(int i=n;i>=a;i--)

typedef long long ll;
const int maxn = 1e5+10;
const int mod =1e9+7;
const int inf = 0x3f3f3f3f;
using namespace std;

int dp[maxn];
int f[maxn];
int main(int argc, char const *argv[])
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		memset(dp,-inf,sizeof(dp));
		memset(f,0,sizeof(f));
		int n;
		scanf("%d",&n);
		rep(i,1,n-1)
		{
			scanf("%d",&f[i]);
		}
		// V = 2*n-2 - n  =  n-2;
		dp[0] = n*f[1];
		rep(i,1,n-2)
		{
			rep(j,i,n-2)
			{
				dp[j] = max(dp[j],dp[j-i]+f[i+1]-f[1]);
			}
		}
		printf("%d\n",dp[n-2] );
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值