1098. Insertion or Heap Sort

1098. Insertion or Heap Sort (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9
Sample Output 2:
Heap Sort
5 4 3 1 0 2 6 7 8 9
做的时候测试点2一直不对,检查了好长时间,我一直以为是堆排序错的,最后发现是插排错的,尴尬。

之前的做法是从后往前检查输入和目标,找到不一致的点,因为没排到的元素肯定是对应相等的,但忽略了一些情况,就是之前过的序列也和原序列一致,

比如 

initial : 3 4 5 1 2

iteration: 3 4 5 1 2

所以换了从前往后找有序的序列,就通过了。

#include <algorithm>
#include <vector>
#include<iostream>

using namespace std;

void adjustheap(vector<int>&ans,int idx)
{
	int tmp=ans[0];
	int root=0;
	for(int i=1;i<idx;i=2*i+1)
	{
		if(i+1<idx&&ans[i]<ans[i+1])
			++i;
		if(tmp>=ans[i])
			break;
		else
		{
			ans[root]=ans[i];
			root=i;
		}
	}
	ans[root]=tmp;
}
int main()
{
	int n;
	cin>>n;
	vector<int>ini(n);
	vector<int>iter(n);
	for(int i=0;i<n;++i)
		cin>>ini[i];
	for(int i=0;i<n;++i)
		cin>>iter[i];
	int idx=1;
	while(idx<n&&iter[idx-1]<=iter[idx])
		idx++;
	vector<int>ans=ini;
	sort(ans.begin(),ans.begin()+idx);
	bool isinsert=true;
	for(int i=idx;i<n;++i)
		if(ans[i]!=iter[i])
		{
			isinsert=false;
			break;
		}
	if(isinsert)
	{
		sort(ans.begin(),ans.begin()+min(idx+1,n));
		cout<<"Insertion Sort"<<endl;
		cout<<ans[0];
		for(int i=1;i<ans.size();++i)
			cout<<" "<<ans[i];
		cout<<endl;
		return 0;
	}
	cout<<"Heap Sort"<<endl;
	idx=n;
	while(idx-1>=0&&iter[idx-1]>=iter[0])
		idx--;
	ans=iter;
	swap(ans[0],ans[--idx]);
	adjustheap(ans,idx);
	cout<<ans[0];
	for(int i=1;i<ans.size();++i)
		cout<<" "<<ans[i];
	cout<<endl;	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值