09-排序3 Insertion or Heap Sort(插入排序或堆排序)

09-排序3 Insertion or Heap Sort (25分)

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.
插入排序迭代,每次重复消耗一个输入元素,并增加排序的输出列表。每次迭代插入排序都会从输入数据中删除一个元素,在排序列表中找到它所属的位置,然后将其插入。重复直到没有输入元素剩余为止。

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.
堆排序将其输入分为已排序和未排序区域,并通过提取最大元素并将其移至已排序区域来迭代地缩小未排序区域。它涉及使用堆数据结构而不是线性时间搜索来找到最大值。

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?
现在给定了整数的初始序列以及排序方法几次迭代的结果,您能否确定我们使用的是哪种排序方法?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.
每个输入文件包含一个测试用例。对于每种情况,第一行给出一个正整数N(≤100)。然后在下一行中,将N个整数作为初始序列。最后一行包含N个数字的部分排序序列。假定目标序列始终是递增的。一行中的所有数字都用空格分隔。

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
对于每个测试用例,请在第一行中“插入排序”或“堆排序”中打印以指示用于获取部分结果的方法。然后运行此方法再进行一次迭代,并在第二行中输出结果序列。可以保证每个测试案例的答案都是唯一的。一行中的所有数字都必须用空格隔开,并且行末必须没有多余的空格。

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9
Sample Output 2:
Heap Sort
5 4 3 1 0 2 6 7 8 9

代码

#include<bits/stdc++.h>
using namespace std;
#define Maxn 120

int a[Maxn],b[Maxn];
int n;
void down(int parent,int size){
	int child=parent*2+1;
	while(child<size){
		if(b[child]<b[child+1]&&child+1<size){
			child++;
		}
		if(b[parent]<b[child]){
			int temp=b[parent];
			b[parent]=b[child];
			b[child]=temp;
			parent=child;
		}
		child=child*2+1;
	}
} 

int main(){
	cin>>n;
	int i,temp,count;
	for(i=0;i<n;i++)
		cin>>a[i];
	for(i=0;i<n;i++)
		cin>>b[i];
	
	for(i=0;i<n-1;i++){
		if(b[i]>b[i+1]){
			i++;
			break;
		}
	}
	count=i;
	for(i;i<n;i++){
		if(a[i]!=b[i]){
			break;
		}
	}
	if(i==n){
		cout<<"Insertion Sort"<<endl;
		sort(b,b+count+1);
		
	}else{
		cout<<"Heap Sort"<<endl;
		for(i=n-1;i>0;i--){
			if(b[i]<b[i-1]){
				i++;
				break;
			}
		}
		int size=i;
		for(i=i/2-1;i>=0;i--){	//初始化堆 
			down(i,size);
		}
		int temp=b[0];
		b[0]=b[size-1];
		b[size-1]=temp;
		down(0,size-1);
	}
	
	cout<<b[0];
	for(i=1;i<n;i++){
		cout<<" "<<b[i];
	}
	
	return 0;
} 


使用函数代码

#include<bits/stdc++.h>
using namespace std;
#define Maxn 120

int a[Maxn],b[Maxn];
int n;

int main(){
	cin>>n;
	int i,temp,count;
	for(i=0;i<n;i++)
		cin>>a[i];
	for(i=0;i<n;i++)
		cin>>b[i];
	
	for(i=0;i<n-1;i++){
		if(b[i]>b[i+1]){
			i++;
			break;
		}
	}
	count=i;
	for(i;i<n;i++){
		if(a[i]!=b[i]){
			break;
		}
	}
	if(i==n){
		cout<<"Insertion Sort"<<endl;
		sort(b,b+count+1);
		
	}else{
		cout<<"Heap Sort"<<endl;
		for(i=n-1;i>0;i--){
			if(b[i]<b[i-1]){
				i++;
				break;
			}
		}
		pop_heap(b, b + i);
	}
	
	cout<<b[0];
	for(i=1;i<n;i++){
		cout<<" "<<b[i];
	}
	
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值