1073. Scientific Notation

1073. Scientific Notation (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9]"."[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input file contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros,

Sample Input 1:
+1.23400E-03
Sample Output 1:
0.00123400
Sample Input 2:
-1.2E+10
Sample Output 2:
-12000000000
输出的在处理过正负号后,有3种情况,一是纯整数,二是整数部分不为0的小数,三是整数部分为0的小数,分别处理一下。
注意一下,即使是如1234.000这种情况,0也不省略。
#include <iostream>  
#include <string>  
#include <sstream>  

using namespace std;  
  
int main()
{  
	string s,ans="";
	getline(cin,s);
	if(s[0]=='-')
		ans+='-';
	int idx=s.find('E');
	string d=s.substr(1,idx-1);
	string e=s.substr(idx+2);
	char sym=s[idx+1];
	stringstream s2ie;
	double digit;
	int exp;
	s2ie<<e;
	s2ie>>exp;
	d=s[1]+s.substr(3,idx-3);
	if(exp==0)
		sym='+';
	if(sym=='+')
	{	
		if(d.size()>exp+1)
			d=d.substr(0,exp+1)+'.'+d.substr(exp+1);
		else
		{
			while(d.size()<=exp)
				d+='0';
		}
		ans+=d;
	}
	else
	{
		ans+="0.";
		while(--exp)
			ans+='0';
		ans+=d;
	}
	cout<<ans<<endl;
	return 0;
}  



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值