HDU 4989

Summary

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 405    Accepted Submission(s): 247


Problem Description
Small W is playing a summary game. Firstly, He takes N numbers. Secondly he takes out every pair of them and add this two numbers, thus he can get N*(N - 1)/2 new numbers. Thirdly he deletes the repeated number of the new numbers. Finally he gets the sum of the left numbers. Now small W want you to tell him what is the final sum.

Input
Multi test cases, every case occupies two lines, the first line contain n, then second line contain n numbers a 1, a 2, ……a n separated by exact one space. Process to the end of file.
[Technical Specification]
2 <= n <= 100
-1000000000 <= a i <= 1000000000

Output
For each case, output the final sum.

Sample Input
  
  
4 1 2 3 4 2 5 5

Sample Output
  
  
25 10
Hint
Firstly small W takes any pair of 1 2 3 4 and add them, he will get 3 4 5 5 6 7. Then he deletes the repeated numbers, he will get 3 4 5 6 7, Finally he gets the sum=3+4+5+6+7=25.

Source


题目的意思看了挺久的。,给你一个N,叫你输入N个数。然后从N个数中任意取两个数相加,得到一个新的数,将所有新的数求和就是答案。注意一点就好,相同的元素只算一个。所以去掉重复的就好。上代码

 

 

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int main()
{
	int n,i,j;
	while(~scanf("%d",&n))
	{
		int a[105];
		int b[10005];
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		__int64 sum=0;
		int l=0;
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(i=0;i<n;i++)
			for(j=i+1;j<n;j++)
			{
				b[l++]=a[i]+a[j];
			}
			sort(b,b+l);
			int n1=unique(b,b+l)-b;  //去掉相同的。此时新数组个数n1.
			for(i=0;i<n1;i++)
				sum+=b[i];
			printf("%I64d\n",sum);
	}
	return 0;
}


 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值