hdu4989(水暴力)

Summary

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1289    Accepted Submission(s): 627


Problem Description
Small W is playing a summary game. Firstly, He takes N numbers. Secondly he takes out every pair of them and add this two numbers, thus he can get N*(N - 1)/2 new numbers. Thirdly he deletes the repeated number of the new numbers. Finally he gets the sum of the left numbers. Now small W want you to tell him what is the final sum.
 

Input
Multi test cases, every case occupies two lines, the first line contain n, then second line contain n numbers a 1, a 2, ……a n separated by exact one space. Process to the end of file.
[Technical Specification]
2 <= n <= 100
-1000000000 <= a i <= 1000000000
 

Output
For each case, output the final sum.
 

Sample Input
  
  
4 1 2 3 4 2 5 5
 

Sample Output
  
  
25 10
Hint
Firstly small W takes any pair of 1 2 3 4 and add them, he will get 3 4 5 5 6 7. Then he deletes the repeated numbers, he will get 3 4 5 6 7, Finally he gets the sum=3+4+5+6+7=25.
 

Source
 

Recommend
heyang   |   We have carefully selected several similar problems for you:   6216  6215  6214  6213

#include<cstdio> 
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
const int maxn=8100;
ll a[maxn],b[maxn];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{	
		for(int i=0;i<n;i++)
			scanf("%lld",&a[i]);
		int num=0;
		for(int i=0;i<n-1;i++)
			for(int j=i+1;j<n;j++)
			{
				b[num++]=a[i]+a[j];
			}
		sort(b,b+num);
		for(int i=1;i<num;i++)
		{
			if(b[i]==b[i-1])
				b[i-1]=0;
		}
		ll sum=0;
		for(int i=0;i<num;i++)
		{
			sum+=b[i];
		}
		printf("%lld\n",sum);
	}

	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值