HDU 1032

The 3n + 1 problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23729    Accepted Submission(s): 8853


Problem Description
Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

Consider the following algorithm:


    1.      input n

    2.      print n

    3.      if n = 1 then STOP

    4.           if n is odd then   n <- 3n + 1

    5.           else   n <- n / 2

    6.      GOTO 2


Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.
 

Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

You can assume that no opperation overflows a 32-bit integer.
 

Output
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).
 

Sample Input
  
  
1 10 100 200 201 210 900 1000
 

Sample Output
  
  
1 10 20 100 200 125
201 210 89 900 1000 174
 

Source

 

 

题意:输入两个数。假如是 1 10.。 对1到10之间的所有整数,进行操作。假如取6。。因为6是偶数,所以除以2得到3。因为3是奇数,所以乘三+1得到10。10是偶数,除以2.

得到5,乘三加一。得到16.除以2,得到8,除以2,得到4,除以二,得到2,除以2,得到1.停止操作。一共操作了8次。问 的是给定区间内所有的整数,进行如上操作,得到一为止,求最大的操作次数是多少?

上代码吧。 WA了好多遍,原因是没有考虑到n,m的输出位置固定,而错误的交换了他们的位置。。orz。。

 

#include <stdio.h>
int main()
{
	int n,m,t,max,i,sum,n1,n2;
	while(scanf("%d%d",&n,&m)!=EOF) 
	{ 
		if(n>m)   //n,m大小不一定,所以保证让n1为小的。
		{
            n1=m,n2=n;
		}
		else
			n1=n,n2=m;
		printf("%d %d ",n,m);  //输出n,m的位置不能变。
		max=0;
		for(i=n1;i<=n2;i++)  //枚举n1到n2的所有整数。
		{
			t=i;sum=1;
			while(t!=1)   //如果不等于一的话,一直循环以下操作。
			{
				if(t%2==1)
					t=3*t+1;
				else
					t=t/2;
				sum++;   //每操作一次,加一个。
			}
			if(sum>max)
				max=sum;  //求出最大操作次数。
		}
		printf("%d\n",max); //输出。
	}
	return 0;
}
 


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值