HDU 3555 Bomb

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 11579    Accepted Submission(s): 4127


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author
fatboy_cw@WHU
 

Source
 

Recommend
zhouzeyong   |   We have carefully selected several similar problems for you:   3554  3556  3557  3558  3559 

 



很水的数位dp,求出不满足的条件,减掉就好了!

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <iostream>
#include <queue>
#include <stack>
using namespace std;
typedef long long ll;
ll f[21][10];
ll dp[21];
void init()
{
    memset(f,0,sizeof(f));
    int i,j,k;
    f[0][0]=1;
    for(i=1; i<=20; i++)
    {
        for(j=0; j<10; j++)
        {
            for(k=0; k<10; k++)
            {
                if(j!=4 ||k!=9)
                    f[i][j]+=f[i-1][k];
            }
            //  cout<<f[i][j]<<" ";
        }
        // cout<<endl;
    }
}
ll solve(ll a)
{
    int i,j;
    int len=0;
    ll ans=0;
    while(a)
    {
        dp[++len]=a%10;
        a/=10;
    }
    dp[len+1]=0;
    for(i=len; i; i--)
    {
        for(j=0; j<dp[i]; j++)
        {
            if(dp[i+1]!=4 ||j!=9)
                ans+=f[i][j];
        }
        if( dp[i+1]==4 &&dp[i]==9)
            break;
    }
    return ans;
}
int main()
{
    int t;
    init();
    scanf("%d",&t);
    while(t--)
    {
        ll a;
        scanf("%lld",&a);
        ll res=solve(a+1);
        cout<<(a+1)-res<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值