"巴卡斯杯" 中国大学生程序设计竞赛 - 女生专场(重现) HDU 5707

Combine String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 17    Accepted Submission(s): 11


Problem Description
Given three strings a , b and c , your mission is to check whether c is the combine string of a and b .
A string c is said to be the combine string of a and b if and only if c can be broken into two subsequences, when you read them as a string, one equals to a , and the other equals to b .
For example, ``adebcf'' is a combine string of ``abc'' and ``def''.
 

Input
Input file contains several test cases (no more than 20). Process to the end of file.
Each test case contains three strings a , b and c (the length of each string is between 1 and 2000).
 

Output
For each test case, print ``Yes'', if c is a combine string of a and b , otherwise print ``No''.
 

Sample Input
  
  
abc def adebcf abc def abecdf
 

Sample Output
  
  
Yes No
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5711  5710  5709  5708  5700 

题意s1 串 s2串 能够组成s3串。
dp
令f[i][j]代表s1用i了个位置,并且匹配,s2用了j个位置并且匹配。所以每次转移是
 f[i-1][j] &&s1[i]==c[i+j]    f[i][j]=1  or  f[i][j-1]&&s2[j]==c[i+j]
#include <iostream>
#include <cmath>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
char s1[2005];
char s2[2005];
char s3[2005];
int f[2005][2005];
void  work()
{
    f[0][0]=1;
    int i,j;
    int l1=strlen(s1+1);
    int l2=strlen(s2+1);
    int l3=strlen(s3+1);
    if(l1+l2!=l3)
    {
        cout<<"No"<<endl;
        return;
    }
    for(i=0; i<=l1; i++)
    {
        for(j=0; j<=l2; j++)
        {
            if(i&&j)
                f[i][j]=0;
            if(f[i-1][j] &&s3[i+j]==s1[i]&&i)
                f[i][j]=1;
            if(f[i][j-1]&&s3[i+j]==s2[j]&&j)
                f[i][j]=1;
        }
    }
    if(f[l1][l2])
        cout<<"Yes"<<endl;
    else
        cout<<"No"<<endl;
}
int main()
{
    while(scanf("%s%s%s",s1+1,s2+1,s3+1)!=EOF)
        work();
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值