HDU 5289

Assignment

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3478    Accepted Submission(s): 1605


Problem Description
Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
 

Input
In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
 

Output
For each test,output the number of groups.
 

Sample Input
  
  
2 4 2 3 1 2 4 10 5 0 3 4 5 2 1 6 7 8 9
 

Sample Output
  
  
5 28
Hint
First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]
 

Author
FZUACM
 

Source
 

Recommend
We have carefully selected several similar problems for you:   5733  5732  5731  5730  5729 

 



算出有多少个区间。满足最大值-最小值 < k

解法:

枚举每个位置x是区间的最左边位置。二分查找,最右的位置r,满足[x,r]的最大值-最小值恰好 < k

r-x+1就是解

用树状数组更新最大最小值,二分位置。





#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include <cmath>
using namespace std;
#define maxn 100007
int tree1[maxn];
int tree2[maxn];
int lowbit(int i)
{
    return i&(-i);
}
void add1(int i,int ans)
{
    while(i<maxn)
    {
        tree1[i]=max(tree1[i],ans);
        i+=lowbit(i);
    }
}
void add2(int i,int ans)
{
    while(i<maxn)
    {
        tree2[i]=min(tree2[i],ans);
        i+=lowbit(i);
    }
}
int add3(int i)
{
    int res=1000000007;
    while(i>0)
    {
        res=min(tree2[i],res);
        i-=lowbit(i);
    }
    return res;
}
int add4(int i)
{
    int res=0;
    while(i>0)
    {
        res=max(tree1[i],res);
        i-=lowbit(i);
    }
    return res;
}
int main()
{
    int t,k,n;
    cin>>t;
    int a[maxn];
    while(t--)
    {
        cin>>n>>k;
        memset(tree1,0,sizeof(tree1));
        memset(tree2,0x7f7f7f,sizeof(tree2));
        for(int j=1; j<=n; j++)
            cin>>a[j];
        long long ans=0;
        for(int j=n; j>=1; j--)
        {
            add1(j,a[j]);
            add2(j,a[j]);
            int low=j;
            int high=n;
            while(low<=high)
            {
                int mid=(low+high)/2;
                int max1=add4(mid);
                int min1=add3(mid);
                if(max1-min1<k)
                    low=mid+1;
                else
                    high=mid-1;
            }
            ans+=low-j;
        }
        cout<<ans<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值