Assignment
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 2839 Accepted Submission(s): 1322
Problem Description
Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
Input
In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
Output
For each test,output the number of groups.
Sample Input
2 4 2 3 1 2 4 10 5 0 3 4 5 2 1 6 7 8 9
Sample Output
5 28HintFirst Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]
找一段区间 区间最大值与最小值只差小于k 共有几段区间
对于一个长度为 L 的区间 , 其子区间总数为 L*(L+1)/2
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
long long A[100100];
int a[100100];
int Min,Max;
int st;
int t;
int n,k;
const int Mod=1e9+7;
int main()
{
scanf("%d",&t);
A[1]=1;
A[0]=0;
for(int i=2;i<=100000;i++)
{
long long j=i;
A[i]=(j+1)*j/2;
}
while(t--)
{
scanf("%d%d",&n,&k);
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
Min=a[1];
Max=a[1];
st=1;
long long ans=0;
for(int i=2;i<=n;i++)
{
if(Max-a[i]>=k||a[i]-Max>=k||Min-a[i]>=k||a[i]-Min>=k)
{
long long sum=0;
sum+=A[i-st]; //上一区间的分组总数
Max=a[i];
Min=a[i];
for(int j=i;j>0;j--) //找左起点
{
if(Max-a[j]>=k||a[j]-Max>=k||Min-a[j]>=k||a[j]-Min>=k)
break;
Max=max(a[j],Max);
Min=min(a[j],Min);
st=j;
}
sum-=A[i-st]; //减掉重复部分
ans+=sum;
continue ;
}
Max=max(a[i],Max);
Min=min(a[i],Min);
}
ans+=A[n-st+1];
printf("%lld\n",ans);
}
}