hdu4417 ​ Super Mario 划分树

Super Mario

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11899    Accepted Submission(s): 4954


 

Problem Description

Mario is world-famous plumber. His “burly” figure and amazing jumping ability reminded in our memory. Now the poor princess is in trouble again and Mario needs to save his lover. We regard the road to the boss’s castle as a line (the length is n), on every integer point i there is a brick on height hi. Now the question is how many bricks in [L, R] Mario can hit if the maximal height he can jump is H.

 

 

Input

The first line follows an integer T, the number of test data.
For each test data:
The first line contains two integers n, m (1 <= n <=10^5, 1 <= m <= 10^5), n is the length of the road, m is the number of queries.
Next line contains n integers, the height of each brick, the range is [0, 1000000000].
Next m lines, each line contains three integers L, R,H.( 0 <= L <= R < n 0 <= H <= 1000000000.)

 

 

Output

For each case, output "Case X: " (X is the case number starting from 1) followed by m lines, each line contains an integer. The ith integer is the number of bricks Mario can hit for the ith query.

 

 

Sample Input

 

1 10 10 0 5 2 7 5 4 3 8 7 7 2 8 6 3 5 0 1 3 1 1 9 4 0 1 0 3 5 5 5 5 1 4 6 3 1 5 7 5 7 3

 

 

Sample Output

 

Case 1: 4 0 0 3 1 2 0 1 5 1

 

 

Source

2012 ACM/ICPC Asia Regional Hangzhou Online

#include <bits/stdc++.h>
using namespace std;
const int MAXN=100005;
int tree[30][MAXN];
int sorted[MAXN];
int toleft[30][MAXN];
void build(int l,int r,int dep){
	if(l==r) return;
	int mid=(l+r)/2;
	int same=mid-l+1;
	for(int i=l;i<=r;i++){
		if(tree[dep][i]<sorted[mid])
			same--;
	}
	int lpos=l,rpos=mid+1; 
	for(int i=l;i<=r;i++){
		if(tree[dep][i]<sorted[mid]){
			tree[dep+1][lpos++]=tree[dep][i];
		}
		else if(tree[dep][i]==sorted[mid]&&same>0){
			tree[dep+1][lpos++]=tree[dep][i];
			same--;
		} 
		else{
			tree[dep+1][rpos++]=tree[dep][i];
		}
		toleft[dep][i]=toleft[dep][l-1]+lpos-l;
	}
	build(l,mid,dep+1);
	build(mid+1,r,dep+1);
}
int query(int L,int R,int l,int r,int dep,int k){
	if(l==r) return tree[dep][l];
	int mid=(L+R)>>1;
	int cnt=toleft[dep][r]-toleft[dep][l-1];//共有cnt个进入左子树 
	if(cnt>=k){
		int newl=L+toleft[dep][l-1]-toleft[dep][L-1];
		int newr=newl+cnt-1;
		return query(L,mid,newl,newr,dep+1,k);
	}
	else{
		int newr=r+toleft[dep][R]-toleft[dep][r];
		int newl=newr-(r-l-cnt);
		return query(mid+1,R,newl,newr,dep+1,k-cnt); 
	}
}
int solve(int n,int s,int t,int h){
	int ans=0;
	int l=1;// 找第mid大,将[s,t]映射为[1,(t-s)+1] 
	int r=(t-s)+1;
	int mid;
	while(l<=r){
		mid=(l+r)>>1;
		int temp=query(1,n,s,t,0,mid);
		if(temp<=h){
			ans=mid;
			l=mid+1;
		}
		else r=mid-1;
	} 
	return ans;
}
int main(){
	int T,n,m,s,t,h;
	scanf("%d",&T);
	int iCase=0;
	while(T--){
		scanf("%d %d",&n,&m);
		memset(tree,0,sizeof(tree));
		for(int i=1;i<=n;i++){
			scanf("%d",&tree[0][i]);
			sorted[i]=tree[0][i];
		}
		sort(sorted+1,sorted+n+1);
		build(1,n,0);
		printf("Case %d:\n",++iCase);
		while(m--){
			scanf("%d %d %d",&s,&t,&h);
			s++;//区间从1开始 
			t++;
			printf("%d\n",solve(n,s,t,h));
			
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值