POJ - 2187 Beauty Contest(旋转卡壳求最远点对)

 

题目:

Bessie, Farmer John's prize cow, has just won first place in a bovine beauty contest, earning the title 'Miss Cow World'. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 ... 10,000. No two farms share the same pair of coordinates. 

Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm 

Output

* Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other. 

Sample Input
4
0 0
0 1
1 1
1 0
Sample Output
2
Hint
Farm 1 (0, 0) and farm 3 (1, 1) have the longest distance (square root of 2) 

题目大意:

给你n个点,让你求出平面最远距离的点对。

思路:

先求出所给的点所形成的凸包,显然最远的点对只能出现在凸包上,然后如何求得这个最远点对呢。

选择两条能刚好卡住凸包的平行线,然后更具卡住的点对来更新最大值,这样旋转一圈就可以得到最大值。

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>

using namespace std;
const int maxn = 50005;
const double eps = 1e-8;
const double PI = acos(-1.0);

//对于浮点数的,><=0的判断。
int sgn(double x)
{
    if(fabs(x)<eps) return 0;
    if(x<0) return -1;
    else return 1;
}
struct Point
{
    double x, y;
    Point() {}
    Point(double _x, double _y)
    {
        x = _x;
        y = _y;
    }
    Point operator -(const Point &b)const
    {
        return Point(x-b.x,y-b.y);
    }
    Point operator +(const Point &b)const
    {
        return Point(x+b.x,y+b.y);
    }
    //叉积
    double operator ^(const Point &b)const
    {
        return x*b.y-y*b.x;
    }
    //点积
    double operator *(const Point &b)const
    {
        return x*b.x+y*b.y;
    }
    //绕原点旋转角度B(弧度制)后,x,y的变化。
    void transXY(double B)
    {
        double tx = x, ty = y;
        x = tx*cos(B)-ty*sin(B);
        y = tx*sin(B)+ty*cos(B);
    }
};
double dist(Point a, Point b)
{
    //勾股定理,使用点积
    return sqrt((a-b)*(a-b));
}
//距离的平方
double dist2(Point a, Point b)
{
    return (a-b)*(a-b);
}

Point p[maxn];
int n;

//做极角排序
bool _cmp(Point p1,Point p2)
{
    double tmp = (p1-p[1])^(p2-p[1]); //向量叉乘
    if(sgn(tmp)>0) return true;
    else if(sgn(tmp)==0&&sgn(dist(p1,p[1])-dist(p2,p[1]))<=0)
        return true;
    else return false;
}

int Stack[maxn],top;

void Graham()
{
    Point p0;
    int k = 1;
    p0 = p[1];
    //找最下方的一个点
    for(int i = 2; i <= n; i++)
    {
        if(p0.y>p[i].y||(p0.y==p[i].y&&p0.x>p[i].x))
        {
            p0 = p[i];
            k = i;
        }
    }
    swap(p[1],p[k]);
    sort(p+2,p+n+1,_cmp);
    if(n == 1)
    {
        top = 1;
        Stack[0] = 1;
        return ;
    }
    if(n == 2)
    {
        top = 2;
        Stack[0] = 1;
        Stack[1] = 2;
        return ;
    }
    Stack[0] = 1;
    Stack[1] = 2;
    top = 2;
    for(int i = 3; i <= n; i++)
    {
        while(top>1&&sgn((p[Stack[top-1]]-p[Stack[top-2]])^(p[i]-p[Stack[top-2]]))<=0) top--;
        Stack[top++] = i;
    }
}
Point p1[maxn];

//旋转卡壳,求两点间距离平方的最大值
int rotating_calipers()
{
    double ans = 0;
    Point v;
    int cur = 1;
    for(int i = 0; i<top; i++)
    {
        v = p1[i]-p1[(i+1)%top]; //指向p[i]
        while((v^(p1[(cur+1)%top]-p1[cur]))<0)  //还没到达平行之前
            cur = (cur+1)%top;
        ans = max(ans,max(dist2(p1[i],p1[cur]),dist2(p1[(i+1)%top],p1[(cur+1)%top])));

    }
    return ans+eps;
}
int main()
{
    scanf("%d", &n);

    for(int i = 1; i <= n; i++)
    {
        scanf("%lf%lf", &p[i].x, &p[i].y);
    }
    Graham();
    for(int i = 0; i < top; i++)
    {
        p1[i] = p[Stack[i]];
    }
    printf("%d\n",rotating_calipers());

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值