POJ—2318 TOYS(叉积判断点和直线关系)

题目:

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
    
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input
5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0
Sample Output
0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2
Hint
As the example illustrates, toys that fall on the boundary of the box are "in" the box.

题目大意:

John每次玩玩具之后总是不收拾,于是他的妈妈给了他一个箱子,但是John是一个很反叛的还在,它只是把玩具扔进箱子里,但是这样玩具就都混在一起了,于是John的父母给箱子装了n块隔板,这样至少能让玩具看起来有序一些。给你隔板的位置,以及John扔的玩具的落下的位置,问你各个隔间里有多少件玩具.

解题思路:

判断点在线上,那就是这个玩具就是在这张隔板的左边,点在线下,那这个玩具就在这张隔板的下面,于是乎,只要二分不断毕竟答案就行。判断点在线上还是线下用叉积就行。

#include<cstring>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<cmath>
#include<iostream>
#include<vector>
#include<map>

using namespace std;
const int maxn = 5005;

struct Point{
    int x, y;
    Point(int x = 0, int y = 0):x(x),y(y){}
}p1[maxn],p2[maxn], pp[maxn];

Point operator - (Point A, Point B){return Point(A.x-B.x,A.y-B.y);}

int Cross(Point A, Point B)
{
    return A.x*B.y-A.y*B.x;
}

int isUp(Point A, Point B, Point C)
{
    Point v1 = B-A, v2 = C-A;
    int flag = Cross(v1,v2);
    if(flag>0)
        return 1;
    else
        return 0;
}
int ans[maxn];

int solve(int pos, int l, int r)
{
    if(l>=r)
        return l;
    int mid = (l+r)/2;
    if(isUp(p2[mid],p1[mid],pp[pos])) return solve(pos,l,mid);
    else
        return solve(pos,mid+1,r);
}


int main()
{
    int n, m, x1, y1, x2, y2;
    while(scanf("%d", &n)&&n)
    {
        scanf("%d%d%d%d%d", &m, &x1, &y1, &x2, &y2);
        memset(ans,0,sizeof(ans));
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d", &p1[i].x, &p2[i].x);
            p1[i].y = y1;
            p2[i].y = y2;
        }
        p1[n].x = x2;
        p1[n].y = y1;
        p2[n].x = x2;
        p2[n].y = y2;

        for(int i = 1; i <= m; i++){
            scanf("%d%d", &pp[i].x, &pp[i].y);
            ans[solve(i,0,n)]++;
        }
        for(int i = 0; i <= n; i++)
            printf("%d: %d\n", i,ans[i]);
        printf("\n");
    }

    return 0;
}

 

 

 

 

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值