POJ1456 Supermarket

 

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16773 Accepted: 7534

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 


Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

明显的贪心,优先买价值高的物品同时尽量将该物品购买时间在截止日期内向后拖,这样可以减少与其它物品的冲突,可用并查集来完成。如果这一天要买某个物品占用了,再买截止日期是当天的物品最晚只能在其前一天购买,那么这天的并查集祖先成为原祖先天数-1

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
	int price;
	int day;
}v[10000];
int cmp(node a, node b)             //价格从大到小排序,贪心优先买贵的
{
		return a.price > b.price;
}
int n, res, fa[10001];
int getfa(int h)
{
	if (h == fa[h])
		return h;
	return fa[h] = getfa(fa[h]);
}
int main()
{
	while (scanf("%d", &n) != EOF)
	{
		res = 0;
		for (int i = 1; i <= 10000; i++)      //并查集初始化,每个截止日期的初始最晚日期是自己
			fa[i] =i;
		for(int i=0;i<n;i++)
		 scanf("%d%d", &v[i].price, &v[i].day);
		sort(v, v+n,cmp);
		for (int i = 0; i <n; i++)
		{
			int t = getfa(v[i].day);
			if (t > 0)                        //可以购买,占用当天时间
			{
				res += v[i].price;
				fa[t] = t- 1;
			}
		}
		cout << res << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值