While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F(1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S andE that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
int u[10010],v[10010],w[10010],dis[10010];
int n,m,k;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int flag=0;
scanf("%d%d%d",&n,&m,&k);
for(int i=0;i<m*2;i++)
{
scanf("%d%d%d",&u[i],&v[i],&w[i]);
i++;
u[i]=v[i-1];
v[i]=u[i-1];
w[i]=w[i-1];//反向赋值
}
for(int i=m*2;i<m*2+k;i++)
{
scanf("%d%d%d",&u[i],&v[i],&w[i]);
w[i]=-w[i];
}
for(int i=1;i<=n;i++)
dis[i]=INF;
dis[1]=0;
for(int i=1;i<=n;i++)
for(int j=0;j<m*2+k;j++)
if(dis[v[j]]>dis[u[j]]+w[j])
dis[v[j]]=dis[u[j]]+w[j];
for(int i=0;i<m*2+k;i++)
if(dis[v[i]]>dis[u[i]]+w[i])
{
flag=1;
break;
}
if(flag)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}//Bellan-Ford