3-1 Point类的构造函数
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
通过本题目的练习可以掌握类的构造函数的定义;
设计一个点类Point,私有数据成员有x、y;公有成员函数有:无参数的构造函数Point(),带参数的构造函数Point(int,int);ShowPoint()输出点对象的信息
在主函数main()中调用相应成员函数,从键盘接收时间对象的x和y的值,并向显示器输出相应的值。
Input
输入2个整数,用一个空格间隔
Output
要求先输出默认的点值,再输出用户构造的点的值
点的格式为:一对圆括号内 x,y的值,中间用“,”间隔;
Example Input
10 11
Example Output
(0,0) (10,11)
Hint
Author
#include<bits/stdc++.h>
using namespace std;
class point
{
public:
point(int a = 0, int b = 0)//默认参数值,<构造函数,同名且没有返回值>
{
x = a;
y = b;
}
void Set()
{
cin>>x>>y;
}
void showpoint()
{
cout<<"("<<x<<","<<y<<")"<<endl;
}
private:
int x, y;
};
int main()
{
int x, y;
point u, v;//建立对象U V时,自动调用构造函数。
v.Set();
u.showpoint();
v.showpoint();
return 0;
}