一天一算法-poj2287-田忌赛马

田忌赛马

(贪心+动规dp

Poj2287

Tian Ji -- The Horse Racing

Time Limit: 5000MS

 

Memory Limit: 65536K

Total Submissions: 15799

 

Accepted: 4871

Description

Here is a famous story in Chinese history. 

That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others. 

Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser. 

Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian. 

Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match. 

It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China? 

 


Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching... 

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses -- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem. 

In this problem, you are asked to write a program to solve this special case of matching problem.

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n ( n<=1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian's horses. Then the next n integers on the third line are the speeds of the king's horses. The input ends with a line that has a single `0' after the last test case.

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

 

 

给出田忌和王的 N 匹马,安排赛马顺序使得田忌得分最多,赢一场+200,输一场-200...第一个数据是各有几匹马,第二行是田忌马的速度,第三行是齐王马的速度

Sample Input

3

92 83 71

95 87 74

2

20 20

20 20

2

20 19

22 18

0

Sample Output

200

0

0

普通贪心法

思路:情况分析

1、田忌当前的最快马比王的最快马慢的时候,显然,我们需要用最慢的马来和王最快的马比。

2、田忌当前的最快的马比王的最快马快的时候,直接比ok

3、田忌当前的最快的马和王的最快马一样快的时候,这个时候需要比较一下最慢的马的价值:

A、田忌最慢的马比王最慢的马快,直接比

B、田忌最慢的马比齐王最慢的马慢或者相等,那我们把最慢的马和王最快的马比,注意判断我们最慢的马是否和王最快的马速度一样

#include<iostream>

#include <algorithm>  

using namespace std;

int main()

{

int n ;

while(cin>>n&&n!=0)

{

int i ;

int tian[1001];  

int qi[1001];  

for(i = 0;i<n;i++)

{

cin>>tian[i];

}

for(i = 0;i<n;i++)

{

cin>>qi[i];

}

sort(tian,tian+n);  

       sort(qi,qi+n);  

int tian_man = 0; //田忌最慢马的位置

int tian_kuai = n-1;//田忌最快马的位置

int qi_man = 0; //齐王最慢马的位置

int qi_kuai = n-1;//齐王最快马的位置

int t = 0; //田忌赢得场数

int q = 0;//齐王赢得场数

int k = n;

while(k--)

{

if(tian[tian_kuai]<qi[qi_kuai]) //情况1

{

q++;

qi_kuai--;

tian_man++;

}

else if(tian[tian_kuai]>qi[qi_kuai])//情况2

{

t++;

qi_kuai--;

tian_kuai--;

}

else  //情况3

{

if(tian[tian_man]>qi[qi_man])

{

t++;

tian_man++;

qi_man++;

}

else

{

if(tian[tian_man]==qi[qi_kuai])

{

tian_man++;

qi_kuai--;

}

else

{

q++;

tian_man++;

qi_kuai--;

}

}

}

}

cout<<200*(t-q)<<endl;

}

return 0;

}

 

 

 

 

 

 

当然这题还可以使用动规来做

DP的做法首先要构造DP的状态,要不断的尝试...

        我们设  dp[i][j] 表示 进行到 第 i 场比赛,我们使用了 j 匹慢马获得的最大收益。

这里不推荐使用因为是个二组数组 效率是fn平方)

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

代码敌敌畏

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值