DFS Tempter of the Bone


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26365 Accepted Submission(s): 7218
Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.
The input is terminated with three 0's. This test case is not to be processed.
Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
Sample Input
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
Sample Output
NO
YES

思想:很明显这道题就是用深搜了,就是剪枝不太好想(我是木有想到大哭),就是比较常见的奇偶剪枝。何为深搜?我想大概就是回溯+剪枝吧。

例如:路径奇偶条件剪枝

仔细观察,从起点到终点的距离的奇偶性决定了所有从起点到终点的可行路径距离的奇偶性!而且这种奇偶相关不随搜索状态的变化而变化。

可以把map看成这样: 
l0 1 0 1 0 1 
l1 0 1 0 1 0 
l0 1 0 1 0 1 
l1 0 1 0 1 0 
l0 1 0 1 0 1 
从为 0 的格子走一步,必然走向为 1 的格子 
从为 1 的格子走一步,必然走向为 0 的格子 
即: 0 ->1或1->0 必然是奇数步 
0->0 走1->1 必然是偶数步 
所以通过分析,可以得到下面这一判定条件,网上有好多别的式子,但本质是一样的。
if (abs(P.x-Q.x)+abs(P.y-Q.y)%2==T%2)    dfs(P);//只需判断一次即可
代码:
 
 

#include<iostream>
#include<cmath>
using namespace std;
char map[9][9];
int sx,sy,ex,ey;
int dx[4]={0,0,1,-1};
int  dy[4]={1,-1,0,0};
int n,m,T;
bool flag;
void dfs(int x,int y,int t)
{   if(x==ex&&y==ey&&t==T) flag=true;
    if(flag) return;
    if(t>=T) return;
    if(abs(abs(x-ex)+abs(y-ey)-(T-t))%2!=0) return;//你走到终点的步数和剩下的时间必须同为奇数或同为偶数。 
    if(x<=0||x>n||y<=0||y>m)return;
    for(int i=0;i<4;i++)
    if(map[x+dx[i]][y+dy[i]]!='X')
       {  map[x+dx[i]][y+dy[i]]='X';
        dfs(x+dx[i],y+dy[i],t+1);
        map[x+dx[i]][y+dy[i]]='.';
        }         return;
  }
  int main()
  {   while(cin>>n>>m>>T&&n&&m&&T)
      {     int c=0;
            for(int i=1;i<=n;++i)
                for(int j=1;j<=m;++j)
                   {  cin>>map[i][j];
                       if(map[i][j]=='S'){sx=i;sy=j;}
                        if(map[i][j]=='D') {ex=i;ey=j;}
                        if(map[i][j]=='X') c++;
                        
                   }//当可以走的步数小于到达所需要的时间,需要走的步数与到达所需时间不同为奇数和偶数时,
                      需要走的步数大于到达时间时,这些都需要剪枝。 
                   if(n*m-c<T||abs(abs(ex-sx)+abs(ey-sy)-T)%2!=0||abs(abs(ex-sx)+abs(ey-sy))>T){cout<<"NO"<<endl;continue;}
                        flag=false;
                        map[sx][sy]='X';
                        dfs(sx,sy,0);
                          map[sx][sy]='.';
                          if(flag) cout<<"YES"<<endl;
                          else cout<<"NO"<<endl;
    }return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值