学校1019: False coin

Description
   The "Gold Bar"bank received information from reliable sources that in their last group of N coins exactly one coin is false and differs in weight from other coins (while all other coins are equal in weight). After the economic crisis they have only a simple balance available. Using this balance, one is able to determine if the weight of objects in the left pan is less than, greater than, or equal to the weight of objects in the right pan. 
In order to detect the false coin the bank employees numbered all coins by the integers from 1 to N, thus assigning each coin a unique integer identifier. After that they began to weight various groups of coins by placing equal numbers of coins in the left pan and in the right pan. The identifiers of coins and the results of the weightings were carefully recorded. 
You are to write a program that will help the bank employees to determine the identifier of the false coin using the results of these weightings.


Input
   The first line of the input file contains a single integer t (1 ≤ t ≤ 30), the number of test cases. 
For each case: the first line contains two integers N and K, separated by spaces, where N is the number of coins (2<=N<=1000 ) and K is the number of weightings fulfilled (1<=K<=100). The following 2K lines describe all weightings. Two consecutive lines describe each weighting. The first of them starts with a number Pi (1<=Pi<=N/2), representing the number of coins placed in the left and in the right pans, followed by Pi identifiers of coins placed in the left pan and Pi identifiers of coins placed in the right pan. All numbers are separated by spaces. The second line contains one of the following characters: '<', '>', or '='. It represents the result of the weighting: 
'<' means that the weight of coins in the left pan is less than the weight of coins in the right pan, 
'>' means that the weight of coins in the left pan is greater than the weight of coins in the right pan,
'=' means that the weight of coins in the left pan is equal to the weight of coins in the right pan.


Output
   For each test:
Write to the output file the identifier of the false coin or 0, if it cannot be found by the results of the given weightings.


Sample Input
1
5 3
2 1 2 3 4
<
1 1 4
=
1 2 5
=
Sample Output

3


原来做的的程序太渣,百度了一个,还不错:

http://blog.163.com/leyni@126/blog/static/16223010220103141193199/

思路:如果天平出现倾斜,那假币一定出现在不等式的一边且只出现在同一边。即要么都出现大于号的左面,就是都出现在右面。所以在不等式一 边出现次数等于不等式次数的是假币(当然这样的假币可能有多个)。

所以,一旦出现等号,两边所有值v[r[i]]都是真值,出现不等号<,左减右加;出现>,左加右减。虽然不精确,但,一旦某个值的绝对值大小==不等式出现次数,就为假币。


#include <stdio.h>
#include<string.h>
#define N 1001
int main()
{
    //freopen("input.txt","r",stdin);
    int n, k, p, total,t,i;
    char sign;
    int v[N];
    int r[N], w[N];
    scanf("%d",&t);
    while(t--)
    {
        memset(v, 0, sizeof(int)*N);
        memset(w, 0, sizeof(int)*N);
        total = 0;
        scanf("%d%d",&n,&k);
        while(k--)
        {
            scanf("%d",&p);
            for (i = 0; i < 2 * p; i++) scanf("%d",&r[i]);
            do
                sign=getchar();
            while(sign=='\n'||sign==' ');
            if (sign == '=') for (i = 0; i < 2 * p; i++) v[r[i]] = 1;
            else if(sign == '<')
            {
                total++;
                for (i = 0; i < p; i++) w[r[i]]--;
                for (; i < 2 * p; i++) w[r[i]]++;
            }
            else if(sign == '>')
            {
                total++;
                for (i = 0; i < p; i++) w[r[i]]++;
                for (; i < 2 * p; i++) w[r[i]]--;
            }
        }


        k = 0;
        p = 0;
        for (i = 1; i <= n; i++)
            if (!v[i])
                if (w[i] == total || w[i] == - total)
                {
                    k++;
                    p = i;
                }
        if (k == 1) printf("%d\n",p);
        else printf("0\n");
    }


    return 0;
}




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值