C - False coin

题目:

The "Gold Bar"bank received information from reliable sources that in their last group of N coins exactly one coin is false and differs in weight from other coins (while all other coins are equal in weight). After the economic crisis they have only a simple balance available (like one in the picture). Using this balance, one is able to determine if the weight of objects in the left pan is less than, greater than, or equal to the weight of objects in the right pan. 
In order to detect the false coin the bank employees numbered all coins by the integers from 1 to N, thus assigning each coin a unique integer identifier. After that they began to weight various groups of coins by placing equal numbers of coins in the left pan and in the right pan. The identifiers of coins and the results of the weightings were carefully recorded. 
You are to write a program that will help the bank employees to determine the identifier of the false coin using the results of these weightings. 

Input

The first line of the input file contains two integers N and K, separated by spaces, where N is the number of coins (2<=N<=1000 ) and K is the number of weightings fulfilled (1<=K<=100). The following 2K lines describe all weightings. Two consecutive lines describe each weighting. The first of them starts with a number Pi (1<=Pi<=N/2), representing the number of coins placed in the left and in the right pans, followed by Pi identifiers of coins placed in the left pan and Pi identifiers of coins placed in the right pan. All numbers are separated by spaces. The second line contains one of the following characters: '<', '>', or '='. It represents the result of the weighting: 
'<' means that the weight of coins in the left pan is less than the weight of coins in the right pan, 
'>' means that the weight of coins in the left pan is greater than the weight of coins in the right pan, 
'=' means that the weight of coins in the left pan is equal to the weight of coins in the right pan. 

Output

Write to the output file the identifier of the false coin or 0, if it cannot be found by the results of the given weightings.

Sample Input

5 3
2 1 2 3 4
<
1 1 4
=
1 2 5
=

Sample Output

3

题意:

给你两个数字N和K,N代表有N枚硬币,K代表下面有K组天平测量的结果;

给你一个数字P,代表左右托盘里各放P枚硬币,然后是2*P个数据,分别是左右托盘中放置的硬币的编号;

给你一个字符,代表天平的平衡结果;

思路:

首先我们可以知道,有问题的硬币不会出现在平衡的天平中,而且有问题的硬币只会出现在天平的一侧,并且,有问题的硬币有且仅有一枚;

代码如下:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;

int n,k,p,i,j,kk;
int book[1100],a[1100],b[1100],pp[1100];
int aa[1100],bb[1100];
char ch[10];

int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        kk=0;
        int sum=0;
        memset(book,-1,sizeof book);//为-1时硬币为假;
        memset(aa,0,sizeof aa);//左天平;
        memset(bb,0,sizeof bb);//右天平;
        for(i=1; i<=k; i++)
        {
            scanf("%d",&p);
            for(j=1; j<=p; j++)
                scanf("%d",&a[j]);
            for(j=1; j<=p; j++)
                scanf("%d",&b[j]);
            scanf("%s",ch);
            if(ch[0]=='=')
            {
                for(j=1; j<=p; j++)
                {
                    book[a[j]]=0;//代表硬币为真;
                    book[b[j]]=0;
                }
            }
            else
            {
                memset(pp,0,sizeof pp);
                for(j=1; j<=p; j++)//代表这枚硬币使用过;
                {
                    pp[a[j]]=1;
                    pp[b[j]]=1;
                }
                if(ch[0]=='>')
                {
                    for(j=1; j<=p; j++)
                        bb[a[j]]=1;//出现;
                    for(j=1; j<=p; j++)
                        aa[b[j]]=1;//出现;
                }
                else
                {
                    for(j=1; j<=p; j++)
                        aa[a[j]]=1;//出现;
                    for(j=1; j<=p; j++)
                        bb[b[j]]=1;//出现;
                }
                for(j=1; j<=n; j++)
                {
                    if(!pp[j])//没有使用过则是真的硬币;
                        book[j]=0;
                    if(bb[j]&&aa[j])//左右两侧都出现过就是真的硬币;
                        book[j]=0;
                }
            }
        }
        for(i=1; i<=n; i++)
        {
            if(book[i]==-1)
            {
                kk=i;
                sum++;
            }
        }
        if(sum==1)//假的硬币,有且仅有一枚;
            printf("%d\n",kk);
        else
            printf("0\n");
    }
    return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值