POJ1837——Balance

Balance
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 13600 Accepted: 8532

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

Source



题目大意:

有一个天平,两臂长为15,有 c (2<=c<=20)个挂钩,g(2<=g<=20)个钩码,求把钩码全挂上能够使天平平衡的情况数。

思路:

dp题,状态实在不会找,就看了一下大牛的博客,然后找到了状态转移方程

dp[i][j+pos[k]*w[i]] += dp[i-1][j];
最终结论:

转化为01背包问题

状态方程dp[i][ j+ w[i]*c[k] ]= ∑(dp[i-1][j])

初始化:dp[0][7500] = 1;   //不挂任何重物时天枰平衡,此为一个方法


Memory: 2464K		Time: 0MS
Language: G++		Result: Accepted
Source Code
#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

int main()
{
    int c, g;
    cin>>c>>g;

    int pos[30];
    for( int i = 1;i <= c;i++ )
        cin>>pos[i];

    int w[30];
    for( int i = 1;i <= g;i++ )
        cin>>w[i];

    int dp[30][15001];
    memset(dp,0,sizeof(dp));
    dp[0][7500] = 1;      //不挂任何钩码就会平衡

    for( int i = 1;i <= g;i++ )
    {
        for( int j = 0;j <= 15000;j++ )
        {
            if( dp[i-1][j] )
            {
                for( int k = 1;k <= c;k++ )
                    dp[i][j+pos[k]*w[i]] += dp[i-1][j];
            }
        }
    }
    cout<<dp[g][7500]<<endl;


    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值