POJ 1753:Flip Game:棋盘枚举1

Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28446 Accepted: 12318

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source


非常有意思的枚举,题目关键在于棋盘的第一行翻转情况确定后,由于影响第一行的只剩下第二行,所以要保证第一行的颜色纯净,就决定了第二行的翻转情况,进而递推出最后一行的翻转情况。因此,棋盘翻转性质:由第一行的翻转情况能递推决定后面n-1行的翻转情况,然后就最后一行的翻转情况对最后一行进行翻转,之前已经保证前n-1行的颜色纯净,只要最后一行也能满足颜色纯净,则翻转成功,否则翻转失败。
使用了0000~1111的枚举方法,并且将全白和全黑的情况进行分离判断,当然,也可以在一起判断。通过枚举所有情况,找出最小值。
#include <stdio.h>
#include<string.h>
int chushi[5][6],min,point[5][6];
char a[5];
void dfs()
{
	int i,j,m,n;
	for(i=1;i<4;i++)
	{
		for(j=1;j<=4;j++)
		{
			point[i+1][j]=(chushi[i][j]+point[i][j]+point[i-1][j]+point[i][j-1]+point[i][j+1])%2;
		}
	}
	for(i=1;i<=4;i++)
	{
		if ( (point[4][i-1] + point[4][i] +point[4][i+1] + point[3][i]) % 2 !=chushi[4][i] )
			break;
	}
	if(i>4)
	{
		j=0;
		for(m=1;m<=4;m++)
		{
			for(n=1;n<=4;n++)
			{
				if(point[m][n])
					j++;
			}
		}
		min=min>j?j:min;
	}
}
void shengcheng()
{
	int i,j,c;
	for(i=0;i<16;i++)
	{
		c=1;
		while(point[1][c]>1)
		{
			point[1][c]=0;
			c++;
			point[1][c]++;
		}
		dfs();
		point[1][1]++;
	}
}
int main()
{
	int i,j,m,n;
	min=10000;
	for(i=1;i<=4;i++)
	{
		scanf("%s",a);
		for(m=0;m<4;m++)
		{
			if(a[m]=='b')
				chushi[i][m+1]=0;
			else
				chushi[i][m+1]=1;
		}
		point[1][i]=0;
		point[0][i]=point[i][0]=point[i][5]=0;
	}
	shengcheng();
	for(i=1;i<=4;i++)
	{
		for(j=1;j<=4;j++)
		{
			if(chushi[i][j])
				chushi[i][j]=0;
			else
				chushi[i][j]=1;
		}
		point[1][i]=0;
		point[0][i]=point[i][0]=point[i][5]=0;
	}
	shengcheng();
	if(min!=10000)
		printf("%d\n",min);
	else
		printf("Impossible\n");
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值