求和

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge). 

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n. 
Input
The input will consist of a series of integers n, one integer per line. 
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer. 
Sample Input
1
100
Sample Output
1

5050

数学公式求解:

#include<stdio.h>
int main()
{
	long long n;
	while(scanf("%lld",&n)!=EOF)
	{
		printf("%lld\n\n",(n+1)*n/2);
	}
	return 0;
}
应该在运算的时候会超int,所以只能用long long

#include<stdio.h>
int main()
{
	double n;
	while(scanf("%lf",&n)!=EOF)
	{
		printf("%.0f\n\n",(n+1)*n/2.0);
	}
	return 0;
}
线段树:

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int an[66000];
struct list
{
	int left;
	int right;
	int sum;
}tree[4*65535];
void build(int i,int left,int right);
void pushup(int i);
int main()
{
	for(int i=1;i<=65540;i++)
		an[i]=i;
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		memset(tree,0,sizeof(tree));
		build(1,1,n);
		printf("%d\n\n",tree[1].sum);
	}
	return 0;
}
void build(int i,int left,int right)
{
	tree[i].left=left;
	tree[i].right=right;
	tree[i].sum=0;
	while(left==right)
	{
		tree[i].sum=an[left];
		return ;
	}
	int mid=(left+right)>>1;
	build(i<<1,left,mid);
	build(i<<1|1,mid+1,right);
	pushup(i); 
}
void pushup(int i)
{
	tree[i].sum=tree[i<<1].sum+tree[i<<1|1].sum;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值