Number Sequence

题解(写得很详细):

点击打开链接http://blog.csdn.net/lyy289065406/article/details/6648504

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another. 
For example, the first 80 digits of the sequence are as follows: 
11212312341234512345612345671234567812345678912345678910123456789101112345678910
Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)
Output
There should be one output line per test case containing the digit located in the position i.
Sample Input
2
8
3
Sample Output
2
2

#include<stdio.h>
#include<math.h>
#define maxn 31269
unsigned an[maxn],sn[maxn];
void table()
{
	for(int i=1;i<maxn;i++)
	{
		an[i]=an[i-1]+log10((double)i)+1;
		sn[i]=sn[i-1]+an[i];
	}
} 
int main()
{
	int t;
	scanf("%d",&t);
	table();
	while(t--)
	{
		int ans,pos,len=0,i,j;
		scanf("%d",&pos);
		for(i=1;sn[i]<pos;i++)
			; 
		pos=pos-sn[i-1];
		for(j=1;pos>len;j++)
		{
			len+=log10((double)j)+1;
		}
		ans=(j-1)/(int)pow(10,len-pos)%10;
		printf("%d\n",ans);
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值