Currency Exchange

真的是思路不够开拓~

这个题目就是从一个起点开始,经过一些环,判断最终起点的值是否增大

spfa既然能求最短路和有负环的情况,那么也能求最长路和正环的情况,本题就是根据后者解题(只要图中存在正环,途中各节点的值就会不断增大,循环就不会退出,此时只要一个节点被遍历的次数大于等于n(节点个数),就表明出现了环,剩下就是模板了……)

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R  AB, C  AB, R  BA and C  BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 
Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10  3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10  -2<=rate<=10  2, 0<=commission<=10  2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10  4
Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
Sample Output
YES
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
#define _max 105
using namespace std;
bool vis[_max];
int head[_max],time[_max],cnt;
double v,dis[_max];
struct Edge
{
	double r,c;
	int v,next;
}edge[_max*2];
void add_edge(int u,int v,double r,double c)
{
	edge[cnt].v=v;
	edge[cnt].r=r;
	edge[cnt].c=c;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}
int spfa(int s,int tol)
{
	memset(dis,0,sizeof(dis));
	memset(vis,0,sizeof(vis));
	memset(time,0,sizeof(time));
	queue<int> q;
	dis[s]=v;
	q.push(s);
	vis[s]=true;
	while(!q.empty())
	{
		int Q=q.front();
		q.pop();
		vis[Q]=false;
		for(int i=head[Q];i!=-1;i=edge[i].next)
		{
			int to=edge[i].v;
			double weight=(dis[Q]-edge[i].c)*edge[i].r;
			if(dis[to]<weight)
			{
				dis[to]=weight;
				if(!vis[to])
				{
					vis[to]=true;
					time[to]++;
					q.push(to);
					if(time[to]>=tol)
						return 1;
				}
			}
		}
	} 
	return 0;
}
int main()
{
	int n,s,m;	
	while(scanf("%d%d%d%lf",&n,&m,&s,&v)!=EOF)
	{
		cnt=0;
		memset(head,-1,sizeof(head));
		memset(edge,0,sizeof(edge));
		for(int i=0;i<m;i++)
		{
			int a,b;
			double c,d,e,f;
			scanf("%d%d%lf%lf%lf%lf",&a,&b,&c,&d,&e,&f);
			add_edge(a,b,c,d);
			add_edge(b,a,e,f);
		}
		if(spfa(s,n))
			printf("YES\n");
		else
			printf("NO\n");
	}	
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值