Wormholes

用spfa判断是否有负环,其次存边的数组要开的大一些(不仅有正常的双向边,还有单向的虫洞)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2..  M+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2..  MW+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back T seconds.
Output
Lines 1..  F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
#include<stdio.h>
#include<queue>
#include<string.h>
#define maxn 505
#define maxm 2505
#define inf 0x3f3f3f3f
using namespace std;
int head[maxn],time[maxn],dis[maxn],cnt;
bool vis[maxn];
struct Edge
{
	int v,w,next;
}edge[3*maxm];
void add_edge(int u,int v,int w)
{
	edge[cnt].v=v;
	edge[cnt].w=w;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}
int spfa(int s,int tol)
{
	memset(dis,inf,sizeof(dis));
	memset(vis,0,sizeof(vis));
	memset(time,0,sizeof(time));
	queue<int> q;
	dis[s]=0;
	vis[s]=true;
	time[s]++;
	q.push(s);
	while(!q.empty())
	{
		int Q=q.front();
		q.pop();
		vis[Q]=false;
		for(int i=head[Q];i!=-1;i=edge[i].next)
		{
			int to=edge[i].v;
			if(dis[to]>dis[Q]+edge[i].w)
			{
				dis[to]=dis[Q]+edge[i].w;
				if(!vis[to])
				{
					vis[to]=true;
					q.push(to);
					time[to]++;
					if(time[to]==tol)
						return 1;
				}
			}
		}
	} 
	return 0;
}
int main()
{
	int f;
	scanf("%d",&f);
	while(f--)
	{
		int n,m,w;
		cnt=0;
		memset(head,-1,sizeof(head));
		memset(edge,0,sizeof(edge));
		scanf("%d%d%d",&n,&m,&w);
		for(int i=0;i<m;i++)
		{
			int s,e,t;
			scanf("%d%d%d",&s,&e,&t);
			add_edge(s,e,t);
			add_edge(e,s,t);
		}
		for(int i=0;i<w;i++)
		{
			int s,e,t;
			scanf("%d%d%d",&s,&e,&t);
			add_edge(s,e,-t);
		}
		if(spfa(1,n))
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值