Wormholes(负权回路)

Problem Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

 

Input
Line 1: A single integer, <i>F</i>. <i>F</i> farm descriptions follow.< br>Line 1 of each farm: Three space-separated integers respectively: <i>N</i>, <i>M</i>, and <i>W</i>< br>Lines 2..<i>M</i>+1 of each farm: Three space-separated numbers (<i>S</i>, <i>E</i>, <i>T</i>) that describe, respectively: a bidirectional path between <i>S</i> and <i>E</i> that requires <i>T</i> seconds to traverse. Two fields might be connected by more than one path.< br>Lines <i>M</i>+2..<i>M</i>+<i>W</i>+1 of each farm: Three space-separated numbers (<i>S</i>, <i>E</i>, <i>T</i>) that describe, respectively: A one way path from <i>S</i> to <i>E</i> that also moves the traveler back <i>T</i> seconds.
 

Output
Lines 1..<i>F</i>: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
 

Sample Input
  
  
2 3 3 1 1 2 2 1 3 4 2 3 1 3 1 3 3 2 1 1 2 3 2 3 4 3 1 8
 

Sample Output
  
  
NO YES
 题意:给你n个点,m条路,最后的 num个黑洞路径,后面的m条路输入的是a-->b的距离,还有花费的时间,num个黑洞可以让你从a-->b倒回时间t,问你有没有可能在哪个点会遇到原来的自己。很有意思的一道题啊,典型的判断是不是负权回路啊。
这也是做判断是不是负权回路的第一个题,收钱二重循环一遍,然后在循环的时候发现还有dis[e]>dis[s]+x[e][s]的时候就存在赋权回路

#if 0
#include<iostream>
#include<cstring>
using namespace std;
int n,m,no,k;   //点,路,黑洞 
struct lu
{
	int a,b,t;
}mapp[10000];
int dis[10000];         

void ford_one()
{
		memset(dis,0x7f,sizeof(dis));
		dis[1]=0; 
		int a,b,t;
		for(int i=1; i<=n-1; i++)
		{	
			bool flag=0;
			for(int j=1; j<=k; j++)
			{
				a=mapp[j].a; 
				b=mapp[j].b;
				t=mapp[j].t;
				
				if(dis[b]>dis[a]+mapp[j].t)
				{
					dis[b]=dis[a]+mapp[j].t;
					flag=1;
				}
			}
			if(flag==0)
				break;
		}
}

int ford_two()
{
	int a,b,t;
	
	    
		for(int j=1; j<=k; j++)
		{
			a=mapp[j].a; b=mapp[j].b;t=mapp[j].t;
			if(dis[b]>dis[a]+mapp[j].t)
				return 1;
		}
	
	return 0;
}


int main()
{
	int T;

	cin>>T;
	while(T--)
	{
		
		cin>>n>>m>>no; 
		k=0;
		for(int i=1; i<=m; i++) 
		{
			int aa,bb,xx;
			cin>>aa>>bb>>xx;
			k++;
			mapp[k].a=aa;
			mapp[k].b=bb;
			mapp[k].t=xx;
			k+=1;
			mapp[k].a=bb;
			mapp[k].b=aa;
			mapp[k].t=xx;
		}
		
		for(int i=1; i<=no; i++)
		{
			int aa,bb,xx;
			cin>>aa>>bb>>xx;
			k+=1;
			mapp[k].a=aa;
			mapp[k].b=bb;
			mapp[k].t=-xx;
		 
		}
		
		ford_one();
		
		if(ford_two())
		{
			cout<<"YES"<<endl;
		}
		else
		{
			cout<<"NO"<<endl;
		}
	}
	
}
#endif 




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值