hdu4911 Inversion 2014 Multi-University Training Contest 5

Inversion

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 137    Accepted Submission(s): 57


Problem Description
bobo has a sequence a 1,a 2,…,a n. He is allowed to swap two  adjacent numbers for no more than k times.

Find the minimum number of inversions after his swaps.

Note: The number of inversions is the number of pair (i,j) where 1≤i<j≤n and a i>a j.
 

Input
The input consists of several tests. For each tests:

The first line contains 2 integers n,k (1≤n≤10 5,0≤k≤10 9). The second line contains n integers a 1,a 2,…,a n (0≤a i≤10 9).
 

Output
For each tests:

A single integer denotes the minimum number of inversions.
 

Sample Input
  
  
3 1 2 2 1 3 0 2 2 1
 

Sample Output
  
  
1 2
 

Author
Xiaoxu Guo (ftiasch)
 

Source
 

Recommend
 


归并排序 直接输出max(cnt-k,0)就可以了。网上粘的模板

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <vector>
#include <queue>
#include <cstdlib>
#include <limits>
#define inf 0x3f3f3f3f
using namespace std;
__int64 cnt;
void merge(__int64 A[], int p, int q, int r) {
    int n1 = q - p + 1;
    int n2 = r - q; 
    __int64 L[n1 + 1]; 
    __int64 R[n2 + 1]; 
    for(int i = 0; i < n1; i++)
        L[i] = A[p + i];
    for(int i = 0; i < n2; i++)
        R[i] = A[q + 1 + i];
    L[n1] = numeric_limits<__int64>::max();
    R[n2] = numeric_limits<__int64>::max();
    int i = 0, j = 0;
    for(int k = p; k <= r; k++) {
        if(L[i] <= R[j]) {
            A[k] = L[i];
            i++;
        } else {
            A[k] = R[j];
            j++;
            cnt += n1 - i;
        }
    }
}
void mergeSort(__int64 A[], int p, int r) {
    if(p >= r)
        return ; 
    int q = (p + r) / 2; 
    mergeSort(A, p, q);
    mergeSort(A, q + 1, r);
    merge(A, p, q, r);
}
int main(){
    int n,k;
    __int64 a[100005];
    while(scanf("%d%d",&n,&k)!=EOF){
        for(int i=0;i<n;i++){
            scanf("%I64d",&a[i]);
        }
        cnt = 0;
        mergeSort(a, 0, n - 1);
        printf("%I64d\n",max(cnt-k,0ll));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值