hdu 3530 Subsequence dp+单调队列

Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4409    Accepted Submission(s): 1441


Problem Description
There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.
 

Input
There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.
 

Output
For each test case, print the length of the subsequence on a single line.
 

Sample Input
  
  
5 0 0 1 1 1 1 1 5 0 3 1 2 3 4 5
 

Sample Output
  
  
5 4
 

Source
 

Recommend
zhengfeng   |   We have carefully selected several similar problems for you:   3535  3529  3528  3527  3415 

题意:找最长的一段序列,使其中的最大最小值之差在[m,k]之间。

思路:维护两个队列分别记录最大最小值,如果差大于k,就使位置靠前的队头+1,并标记该位置。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N=100005;
int a,ans,l,front1,back1,front2,back2;
struct node
{
    int x;
    int p;
}maxq[N],minq[N];
int main()
{
    int n,m,k;
    while(scanf("%d%d%d",&n,&m,&k)!=EOF){
        front1=back1=front2=back2=ans=l=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&a);
            while(front1<back1&&maxq[back1-1].p<a)back1--;
            while(front2<back2&&minq[back2-1].p>a)back2--;
            maxq[back1].p=a;
            maxq[back1++].x=i;
            minq[back2].p=a;
            minq[back2++].x=i;
            while(maxq[front1].p-minq[front2].p>k)
                l=maxq[front1].x>minq[front2].x?minq[front2++].x:maxq[front1++].x;
            if(maxq[front1].p-minq[front2].p>=m)ans=max(ans,i-l);
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值