zoj 2391 Beautiful People 最长上升子序列

Beautiful People

Time Limit: 5 Seconds       Memory Limit: 32768 KB       Special Judge

The most prestigious sports club in one city has exactly N members. Each of its members is strong and beautiful. More precisely, i-th member of this club (members being numbered by the time they entered the club) has strength Si and beauty Bi. Since this is a very prestigious club, its members are very rich and therefore extraordinary people, so they often extremely hate each other. Strictly speaking, i-th member of the club Mr X hates j-th member of the club Mr Y if Si <= Sj and Bi >= Bj or if Si >= Sj and Bi <= Bj (if both properties of Mr X are greater then corresponding properties of Mr Y, he doesn��t even notice him, on the other hand, if both of his properties are less, he respects Mr Y very much).

To celebrate a new 2005 year, the administration of the club is planning to organize a party. However they are afraid that if two people who hate each other would simultaneouly attend the party, after a drink or two they would start a fight. So no two people who hate each other should be invited. On the other hand, to keep the club prestige at the apropriate level, administration wants to invite as many people as possible.

Being the only one among administration who is not afraid of touching a computer, you are to write a program which would find out whom to invite to the party.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Input

The first line of the input file contains integer N - the number of members of the club. (2 <= N <= 100 000). Next N lines contain two numbers each - Si and Bi respectively (1 <= Si, Bi <= 109).


Output

On the first line of the output file print the maximum number of the people that can be invited to the party. On the second line output N integers - numbers of members to be invited in arbitrary order. If several solutions exist, output any one.


Sample Input

1

4
1 1
1 2
2 1
2 2


Sample Output

2
1 4


题意:找最长的子序列 满足t[i].s<t[i+1].s,t[i].b<t[i+1].b.

思路:最长上升子序列的变形,记录路径。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#include <vector>
#include <queue>
#include <map>
using namespace std;
const int N=100005;
const int inf=0x3f3f3f3f;
struct node
{
    int s,b,id;
} t[N];
int dp[N],path[N];
int n;
int cmp(node a,node b)
{
    if(a.s==b.s)
        return a.b>b.b;
    return a.s<b.s;
}
int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--){
        scanf("%d",&n);
        for(int i=1; i<=n; i++){
            scanf("%d%d",&t[i].s,&t[i].b);
            t[i].id=i;
        }
        sort(t+1,t+n+1,cmp);
        dp[1]=1;
        int k=1;
        for(int i=2; i<=n; i++){
            if(t[i].b>t[dp[k]].b){
                path[i]=dp[k];
                dp[++k]=i;
            }
            else{
                int l=1,r=k;
                while(l<=r){
                    int m=(r+l)/2;
                    if(t[dp[m]].b<t[i].b)l=m+1;
                    else r=m-1;
                }
                dp[l]=i;
                path[i]=dp[l-1];
            }
        }
        printf("%d\n",k);
        int i=dp[k--];
        printf("%d",t[i].id);
        while(k--){
            i=path[i];
            printf(" %d",t[i].id);
        }
        printf("\n");
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值