Bellovin
Accepts: 428
Submissions: 1685
Time Limit: 6000/3000 MS (Java/Others)
Memory Limit: 131072/131072 K (Java/Others)
问题描述
Peter有一个序列a1,a2,...,an. 定义F(a1,a2,...,an)=(f1,f2,...,fn), 其中fi是以ai结尾的最长上升子序列的长度. Peter想要找到另一个序列b1,b2,...,bn使得F(a1,a2,...,an)和F(b1,b2,...,bn)相同. 对于所有可行的正整数序列, Peter想要那个字典序最小的序列. 序列a1,a2,...,an比b1,b2,...,bn字典序小, 当且仅当存在一个正整数i (1≤i≤n)满足对于所有的k (1≤k<i)都有ak=bk并且ai<bi.
输入描述
输入包含多组数据, 第一行包含一个整数T表示测试数据组数. 对于每组数据: 第一行包含一个整数n (1≤n≤100000)表示序列的长度. 第二行包含n个整数a1,a2,...,an (1≤ai≤109).
输出描述
对于每组数据, 输出n个整数b1,b2,...,bn (1≤bi≤109)表示那个字典序最小的序列.
输入样例
3 1 10 5 5 4 3 2 1 3 1 3 5
输出样例
1 1 1 1 1 1 1 2 3
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<string>
#include<ctype.h>
#include<math.h>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<bitset>
#include<algorithm>
#include<time.h>
using namespace std;
void fre() { freopen("c://test//input.in", "r", stdin); freopen("c://test//output.out", "w", stdout); }
#define MS(x,y) memset(x,y,sizeof(x))
#define MC(x,y) memcpy(x,y,sizeof(x))
#define MP(x,y) make_pair(x,y)
#define ls o<<1
#define rs o<<1|1
typedef long long LL;
typedef unsigned long long UL;
typedef unsigned int UI;
template <class T1, class T2>inline void gmax(T1 &a, T2 b) { if (b>a)a = b; }
template <class T1, class T2>inline void gmin(T1 &a, T2 b) { if (b<a)a = b; }
const int N = 1e5+10, M = 0, Z = 1e9 + 7, ms63 = 0x3f3f3f3f;
int casenum, casei;
int n, a[N], d[N], f[N];
int main()
{
scanf("%d", &casenum);
for (casei = 1; casei <= casenum; ++casei)
{
scanf("%d", &n);
for (int i = 1; i <= n; ++i)scanf("%d", &a[i]);
int len = 0; d[0] = -1e9;
for (int i = 1; i <= n; ++i)
{
if (a[i] > d[len])d[++len] = a[i], f[i] = len;
else
{
int l = 1;
int r = len;
while (l < r)
{
int mid = (l + r) >> 1;
if (a[i] <= d[mid])r = mid;
else l = mid + 1;
}
d[l] = a[i];
f[i] = l;
}
printf("%d%c", f[i], i == n ? '\n' : ' ');
}
}
return 0;
}
/*
【trick&&吐槽】
比赛的时候把f[i]求成了a[i]加入数组之后的LIS,导致了一次WA,囧
【题意】
有n(1e5)个数a[]
用fa[i]表示以a[i]为尾端点的LIS
让你用最小字典序的正整数序列b[]代替a[]使得以b[]为尾端点的LIS fb[]恰好等于fa[]
【类型】
LIS
【分析】
我们直接求出f[],f[]就是答案>.<
注意f[i]代表的是以i为尾端点的LIS哦
【时间复杂度&&优化】
O(nlogn)
【数据】
10
2 3 4 5 6 1 2 3 4 7
*/