Bellovin HDU - 5748 (最长上升子序列)

Bellovin

HDU - 5748

Peter has a sequence a1,a2,...,an and he define a function on the sequence -- F(a1,a2,...,an)=(f1,f2,...,fn) , where fi is the length of the longest increasing subsequence ending with ai .

Peter would like to find another sequence b1,b2,...,bn in such a manner that F(a1,a2,...,an) equals to F(b1,b2,...,bn) . Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.

The sequence a1,a2,...,an is lexicographically smaller than sequence b1,b2,...,bn , if there is such number i from 1 to n , that ak=bk for 1k<i and ai<bi

.
Input
There are multiple test cases. The first line of input contains an integer T , indicating the number of test cases. For each test case:

The first contains an integer n (1n100000) -- the length of the sequence. The second line contains n integers a1,a2,...,an (1ai109)
.
Output
For each test case, output n integers b1,b2,...,bn (1bi109)
denoting the lexicographically smallest sequence.
Sample Input
3
1
10
5
5 4 3 2 1
3
1 3 5
Sample Output
1
1 1 1 1 1
1 2 3
题意:给n个数字表示a序列,求字典序最小的b序列中每个位置的LIS跟a序列一样

思路:字典序最小其实就是a序列的LIS

 其思想源自最长上升子系列的lower_bound的优化   最长上升子序列问题l

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;

int a[100100];
int dp[100100];//dp[i]储存长度为i的上升子序列中末尾元素最小值
int ans[100100];
int n;
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        int i;
        for(i = 1; i <= n; i++){
            scanf("%d",&a[i]);
            dp[i] = INF;
        }
        int pos;
        //这道题不是让求最长上升子序列,而是求出以每个元素为末尾时的最长上升序列
        for(i = 1; i <= n; i++){
            pos = lower_bound(dp+1,dp+1+n,a[i])-dp;//每次查找
            ans[i] = pos;//记录位置
            dp[pos] = a[i];//更新dp数组
        }
        for(i = 1; i <= n; i++){
            if(i==1)
                printf("%d",ans[i]);
            else
                printf(" %d",ans[i]);
        }
        printf("\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值