LightOj 1094 Farthest Nodes in a Tree【树的直径】

题目:

Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000)denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output

For each case, print the case number and the maximum distance.

Sample Input

2

4

0 1 20

1 2 30

2 3 50

5

0 2 20

2 1 10

0 3 29

0 4 50

Sample Output

Case 1: 100

Case 2: 80

题目大意:

       给定一棵带权树,求树上任意两点之间权值最大的路径的权值。

解题思路:

       树的直径模板题。https://blog.csdn.net/sodacoco/article/details/85926147

实现代码:

/*
  程序实现用的是邻接表来表示树结构.
  Head[i]==j 表示与i结点连接的边组成了一条链表, 其中第j条边是这条链的头一个元素, 接着通过j可以找到剩余的(与i连接的)边.
  Edge是用来表示每条边的结构.
  BFS返回从s结点能走到的最远的点的编号
*/
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
const int maxn=50000+5;
const int maxm=100000+5;

//有向边
struct Edge
{
    Edge(){}
    Edge(int to,int cost,int next):to(to),cost(cost),next(next){}
    int to;   //边尾部
    int cost; //边距离
    int next; //指向下条边
}edges[maxm];
int cnt=0;    //边总数
int head[maxn];//头结点

//添加两条有向边
void AddEdge(int u,int v,int cost)
{
    edges[cnt]=Edge(v,cost,head[u]);
    head[u]=cnt++;
    edges[cnt]=Edge(u,cost,head[v]);
    head[v]=cnt++;
}

//距离
int dist[maxn];

//BFS返回从s出发能到达的最远点编号
int BFS(int s)
{
    int max_dist=0;
    int id=s;
    queue<int> Q;
    memset(dist,-1,sizeof(dist));
    dist[s]=0;
    Q.push(s);

    while(!Q.empty())
    {
        int u=Q.front(); Q.pop();
        if(dist[u]>max_dist)
            max_dist=dist[id=u];
        for(int i=head[u]; i!=-1; i=edges[i].next)
        {
            Edge &e=edges[i];
            if(dist[e.to]==-1)
            {
                dist[e.to]=dist[u]+e.cost;
                Q.push(e.to);
            }
        }
    }
    return id;
}

int main()
{
    int n,m,t,num=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        cnt=0;
        memset(head,-1,sizeof(head));
        int u,v,cost;
        char c;
        for(int i=1;i<=n-1;i++)
        {
            scanf("%d%d%d",&u,&v,&cost);
            AddEdge(u,v,cost);
        }
        printf("Case %d: %d\n",num++,dist[BFS(BFS(u))]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值