LightOJ1094Farthest Nodes in a Tree(BFS+树的直径)

8 篇文章 0 订阅
7 篇文章 0 订阅
Description
Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input
Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output
For each case, print the case number and the maximum distance.

Sample Input
2
4
0 1 20
1 2 30
2 3 50
5
0 2 20
2 1 10
0 3 29
0 4 50
Sample Output
Case 1: 100

Case 2: 80

提议:找树的直径也就是最远距离。

思路:第一次接触树的直径这种题,思路很乱,大致是先随便搜索一个点a找到与其最远距离的那个点b,然后再搜索b就可以找到树直径了。至于代码思路还是有些不清晰,照着模板写的容我今天再瞅瞅!

代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
#define MAXN 93000+10
struct st{
    int from;
    int to;
    int val;
    int next;
}shu[MAXN*2];
int head[MAXN];//头'指针'
int edgenum;//边数
void addedge(int u,int v,int w){
    shu[edgenum].from=u;//起点
    shu[edgenum].to=v;//终点
    shu[edgenum].val=w;//权值
    shu[edgenum].next=head[u];//指向下一个边
    head[u]=edgenum++;
}
int ans;
int Tnode;
int n;
int dist[MAXN];//以该店为尾点的最长距离
int vis[MAXN];//记录是否访问过
void bfs(int s){
    memset(dist, 0, sizeof(dist)); 
    memset(vis,0, sizeof(vis));
    queue<int >q; 
    q.push(s);Tnode=s;ans=0;
    vis[s]=1;
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        for(int i=head[u];i!=-1;i=shu[i].next)
        {
            int v=shu[i].to;
            if(!vis[v]&&dist[v]<dist[u]+shu[i].val)
            {
                vis[v]=1;
                dist[v]=dist[u]+shu[i].val;
                if(ans<dist[v])
                {
                    ans=dist[v];
                    Tnode=v;
                }
                q.push(v);        
            }
        }
    }
}
int main()
{
		int t;
		scanf("%d",&t);
		int k=1;
		while(t--)
		{
        scanf("%d",&n);
        ans=0;
        memset(head,-1,sizeof(head));
        edgenum=0;
        for(int i=0;i<n-1;i++)
        {
        int a,b,c;
        scanf("%d%d%d",&a,&b,&c);
        addedge(a,b,c);
        addedge(b,a,c);    
        }
        bfs(0);
        bfs(Tnode);
        printf("Case %d: %d\n",k++,ans);         
        }	
        return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值