蛇形图

Problem Description

在n*n方陈里填入1,2,...,n*n,要求填成蛇形。例如n=4时方阵为:
1  2  6  7
3  5  8  13
4  9  12 14
10 11 15 16

Input

直接输入方阵的维数,即n的值。(n<=100)

Output

输出结果是蛇形方阵。

Sample Input

3

Sample Output

1 2 6
3 5 7
4 8 9

 

 

#include<cstdio>
#include<iostream>
using namespace std;

int num[106][106];
int n;
int flag;

void hehe()
{
	for(int k=1;k<=n;k++)
	{
		printf("%d",num[k][1]);
		for(int o=2;o<=n;o++)
			printf(" %d",num[k][o]);
		printf("\n");
	}

}
int main()
{
	int i;
	while(cin>>n)
	{
		int x=1,y=1;
		num[1][1]=1;
		for(i=2;i<=(n*n-n+2)/2+n-1;i++)
		{
			if(x==1)
			{
				y++;
				num[x][y]=i;
			
				i++;
				y--;
				x++;
				num[x][y]=i;
				flag=1;
				
				continue;
			}
			if(y==1)
			{
				x++;
				num[x][y]=i;
			
				i++;
				y++;
				x--;
				num[x][y]=i;
				flag=0;
				
				continue;
			}
			
			if(flag==1)
			{
				y--;
				x++;
				num[x][y]=i;
			}
			else
			{
				y++;
				x--;
				num[x][y]=i;
				
			}		
		}
		for(i=i;i<=n*n;i++)
		{
			if(x==n)
			{
				y++;
				num[x][y]=i;
				
				i++;
				y++;
				x--;
				num[x][y]=i;
				flag=1;
				
				continue;
			}
			if(y==n)
			{
				x++;
				num[x][y]=i;
			
				i++;
				y--;
				x++;
				num[x][y]=i;
				flag=0;
			
				continue;
			}
			
			if(flag==0)
			{
				y--;
				x++;
				num[x][y]=i;
			
			}
			else
			{
				y++;
				x--;
				num[x][y]=i;
			
			}
		}	
		hehe();	
	}
	return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值